xpra icon
Bug tracker and wiki

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#354 closed defect (fixed)

PIL imports to work with pillow

Reported by: Michael Weber Owned by: Antoine Martin
Priority: major Milestone: 0.9
Component: core Version:
Keywords: Cc:

Description (last modified by Antoine Martin)

Changeset r3593 indicated a compatibility with pillow (PIL replacement) but for the import updates to work, see links for bug report and patches.

Change History (3)

comment:1 Changed 7 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to Antoine Martin
Status: newassigned

Thanks.
I never bothered to test compatibility with pillow - only the ebuild got updated.

It's unfortunate that this change forces me to also add lots of "#@UnresolvedImport" to avoid pydev warnings.
Oh well, done for trunk in r3600. I will probably apply this to the 0.9.x branch since a few distros are now moving to pillow, unless 0.10 stabilizes first (unlikely).

comment:2 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

The fix was released as part of v0.9.6 (commit r3648)

comment:3 Changed 6 years ago by Antoine Martin

Milestone: future0.9

(setting correct milestone the work was completed in)

Note: See TracTickets for help on using tickets.