xpra icon
Bug tracker and wiki

Opened 7 years ago

Closed 7 years ago

#359 closed defect (fixed)

window icon goes missing when resuming

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: critical Milestone: 0.10
Component: core Version:
Keywords: Cc:

Description (last modified by Antoine Martin)

This only affects some apps (vbox, ensight,..) and only when started from another app (a terminal is the easiest way):

  • start a session with xterm
  • start VirtualBox from xterm (or other terminal app) - the vbox window has the correct vbox icon
  • disconnect
  • re-connect - the terminal window icon is correct but the vbox window uses same icon as the terminal window!?

I've tried:

  • disabling self.raw_window_icons so the icon would be sent with the metadata rather than after (in case it was a window setup race) - no effect
  • saving the window icon to file on the client side to verify that we are sending the correct one with:
    pixbuf.save("window-icon%s.png" % time.time(), "png")
    
  • starting vbox directly (without a terminal) shows the correct icon every time

I'm out of ideas!

Change History (3)

comment:1 Changed 7 years ago by Antoine Martin

Description: modified (diff)
Status: newassigned

And now I can't reproduce it anymore.
But before that, the prime suspect was the group-leader code.

comment:2 Changed 7 years ago by Antoine Martin

Priority: majorcritical

Can reproduce like so:

  • start xterm
  • start calculator from xterm
  • disconnect
  • resume

The calculator will end up with the same window icon as the xterm

comment:3 Changed 7 years ago by Antoine Martin

Resolution: fixed
Status: assignedclosed
Summary: virtualbox window icon goes missing when resumingwindow icon goes missing when resuming

It was a race, which explains why only some applications showed the problem some of the time.

Fixed in r3787

Note: See TracTickets for help on using tickets.