xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#436 closed defect (fixed)

debian bug #725076 xpra: window titles say <unknown machine>

Reported by: Timo Juhani Lindfors Owned by: onlyjob
Priority: major Milestone: 0.10
Component: client Version:
Keywords: Cc: onlyjob@…

Description (last modified by Antoine Martin)

Forwarded from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=725076

Package: xpra
Version: 0.10.4+dfsg-2
Severity: normal

Since I upgraded xpra I noticed that window titles no longer show the hostname but instead <unknown machine>. Please the attached screencast for more information.

-- System Information:

Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.10-3-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages xpra depends on:
ii  libavcodec54              6:9.8-2+b1
ii  libc6                     2.17-93
ii  libgtk2.0-0               2.24.21-1
ii  libswscale2               6:9.8-2+b1
ii  libvpx1                   1.2.0-2
ii  libx11-6                  2:1.6.1-1
ii  libx264-133               2:0.133.2339+git585324f-2
ii  libxcomposite1            1:0.4.4-1
ii  libxdamage1               1:1.1.4-1
ii  libxfixes3                1:5.0.1-1
ii  libxrandr2                2:1.4.1-1
ii  libxtst6                  2:1.2.2-1
ii  python                    2.7.5-5
ii  python-gtk2               2.24.0-3+b1
ii  x11-xserver-utils         7.7+1
ii  xserver-xorg-input-void   1:1.4.0-1+b2
ii  xserver-xorg-video-dummy  1:0.3.7-1+b1

Versions of packages xpra recommends:
ii  openssh-client  1:6.2p2-6
ii  python-imaging  1.1.7-4
ii  python-webm     0.2.2-2
ii  ssh-askpass     1:1.2.4.1-9

Versions of packages xpra suggests:
ii  gstreamer0.10-plugins-bad   0.10.23-7.1
ii  gstreamer0.10-plugins-good  0.10.31-3+nmu1
ii  openssh-server              1:6.2p2-6
ii  pulseaudio                  4.0-6+b1
ii  pulseaudio-utils            4.0-6+b1
ii  python-dbus                 1.2.0-2+b1
pn  python-gst0.10              <none>
pn  python-gtkglext1            <none>

Attachments (1)

Screencast from 10-01-2013 10:41:45 AM.webm (650.1 KB) - added by Timo Juhani Lindfors 6 years ago.
screencast that shows "<unknown machine>" in window title

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by Timo Juhani Lindfors

screencast that shows "<unknown machine>" in window title

comment:1 Changed 6 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to Timo Juhani Lindfors

FWIW: works fine here.
Any idea when this problem started? 0.10.x?

comment:2 Changed 6 years ago by Antoine Martin

Please post:

  • from the server:
    python -c "import socket;print(socket.gethostname().encode('utf8'))"
    
  • does setting a hardcoded title work? ie:
    xpra attach --title TESTING ...
    
  • does setting a custom title with the window title work? ie:
    xpra attach --title 'XYZ-@title@-ABC' ...
    

(the window title should contain the application's title)

  • does setting a custom title with the hostname in it work? ie:
    xpra attach --title 'XYZ-@client-machine@-ABC' ...
    

(the window title should contain the server hostname)

If possible, try running with "-d all" and grepping for "client-machine".

comment:3 Changed 6 years ago by onlyjob

Cc: onlyjob@… added

comment:4 Changed 6 years ago by onlyjob

When Xpra just attached to the session everything appears normal but titles change to "on <unknown machine>" as soon as I click (change) tab in Iceweasel (aka Firefox) or in GnuCash. To reproduce issue in kmail it is enough to change active email folder once.
All commands with various "--title" parameters appears to work for me; I see correct host name when I attach with "-d all 2>&1 | grep client-machine".

I first noticed the problem in 0.10.4 or 0.10.3 but I didn't pay much attention to it so it could have appear earlier.

Last edited 6 years ago by onlyjob (previous) (diff)

comment:5 Changed 6 years ago by Antoine Martin

Milestone: 0.10
Owner: changed from Timo Juhani Lindfors to Antoine Martin
Priority: minormajor
Status: newassigned

Hah, OK. Looks like the client app changes its title when you change tabs, we forward the new title to the client, and somehow when we do the string substitution the client-machine value has changed from whatever-it-should-be back to unknown-machine... (the default)

comment:6 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to onlyjob
Status: assignednew

With this new info, it was pretty easy to find the problem (I haven't looked at how old this is - probably not very old, maybe 0.10.x only).

The completely untested but obviously correct fix is in r4496 (see changeset message for details - it fits the symptoms perfectly), does this work for you?

Last edited 6 years ago by Antoine Martin (previous) (diff)

comment:7 Changed 6 years ago by onlyjob

Fix from r4496 works very well, thank you. :)

comment:8 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Applied to 0.10.x in r4500, 0.10.6 tagged with it in r4501

Note: See TracTickets for help on using tickets.