xpra icon
Bug tracker and wiki

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#45 closed defect (duplicate)

avoid client error due to missing pulseaudio X11 props

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: minor Milestone: 0.0.7.x
Component: android Version: 0.0.7.32
Keywords: Cc:

Description

Missing window or missing property or wrong property type PULSE_SERVER (latin1)
Traceback (most recent call last):
   File "/usr/lib/python2.7/dist-packages/wimpiggy/prop.py", line 277, in prop_get
     data = trap.call_synced(XGetWindowProperty, target, key, atom)
   File "/usr/lib/python2.7/dist-packages/wimpiggy/error.py", line 101, in call_synced
     return self._call(False, fun, args, kwargs)
   File "/usr/lib/python2.7/dist-packages/wimpiggy/error.py", line 86, in _call
     value = fun(*args, **kwargs)
   File "bindings.pyx", line 484, in wimpiggy.lowlevel.bindings.XGetWindowProperty (wimpiggy/lowlevel/bindings.c:4189)
 NoSuchProperty: PULSE_SERVER

and also for PULSE_COOKIE and PULSE_ID

Also, should the property name be using latin1?

Change History (2)

comment:1 Changed 9 years ago by Antoine Martin

Resolution: duplicate
Status: newclosed

dupe of #46

comment:2 Changed 9 years ago by Antoine Martin

Version: 0.0.7.32
Note: See TracTickets for help on using tickets.