xpra icon
Bug tracker and wiki

Opened 3 years ago

Closed 3 years ago

#458 closed defect (worksforme)

Client area resize occasionally out of step with window resize

Reported by: madmonk Owned by: madmonk
Priority: minor Milestone: 0.12
Component: client Version:
Keywords: Cc:

Description

This seems to be a lot worse running the client under KDE/Kwin. I assume a message is being lost somewhere along the way. It really only happens when I resize the window back and forth very rapidly between small and large and try and let go before the client has caught up. You might describe it as a forced error but I'm pretty sure if I can make it happen by abusing the resize it will also happen occasionally during normal use.

I don't know whether this is fixable by sending an additional message on mouse up after checking if the window size has altered or if there are any other messages or hooks that could be used for the same effect.

Anyway perhaps when there are no other bugs to look at you can look at this one :)

Change History (4)

comment:1 Changed 3 years ago by madmonk

Actually thinking about it I only started to check if there was an issue because I saw a thick black border inside the window after resizing one time.

comment:2 Changed 3 years ago by Antoine Martin

Milestone: 0.12
Owner: changed from Antoine Martin to Antoine Martin
Priority: trivialminor
Status: newassigned

Probably related to #252 and #107

Unless KDE/Kwin is very broken (which I doubt), we are already getting all the events that we should. The problem is more likely to be a race between the client resizing and the application re-configuring or re-sizing itself in response to those changes: this is inherently racy. Each end runs with its own X11 server time so there is no easy way to synchronize events and decide who is right.

This is not a regression, so tentatively scheduling for 0.12

comment:3 Changed 3 years ago by Antoine Martin

Owner: changed from Antoine Martin to madmonk
Status: assignednew

Is this fixed in 0.10.x or 0.11? #252 was reported as being fixed.

comment:4 Changed 3 years ago by Antoine Martin

Resolution: worksforme
Status: newclosed

Not heard back, closing.

Note: See TracTickets for help on using tickets.