xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#467 closed defect (fixed)

Launch GUI fails to connect

Reported by: alas Owned by: alas
Priority: major Milestone: 0.11
Component: client Version:
Keywords: Launcher Cc:

Description (last modified by Antoine Martin)

Using win client 0.11.0 r4903 the Launch GUI fails with the following message server-side:

2013-12-10 15:12:59,945 New connection received: SocketConnection(('10.0.32.172', 1201) - ('10.0.11.181', 64880))
2013-12-10 15:13:09,954 connection timedout: Protocol(SocketConnection(('10.0.32.172', 1201) - ('10.0.11.181', 64880)))
2013-12-10 15:13:10,956 connection closed after 0 packets received (0.0 bytes) and 1 packets sent (26 bytes)
2013-12-10 15:13:10,957 Connection lost

osx 0.11.0r4905 Launch GUI fails with the same message.

(There is no Launcher GUI option for choosing on/off for opengl.)

Regressing with the osx client, I find that the 0.11.0 r4745 Launcher GUI works as expected, but 0.11.0 r4748 Launcher GUI fails as above. (Uninstalling and re-installing previous win revisions is tedious, but I can go through the regressions with windows too, if needed.)

Change History (4)

comment:1 Changed 6 years ago by alas

I just noticed that the Launcher GUIs, when their connections timeout, don't exit. With the osx client I had to use force quit to kill them. With windows I had to use the task manager to force quit (and, not noticing this at first, the hanging process made the uninstall attempt to try some regression testing fail).

comment:2 Changed 6 years ago by Antoine Martin

Unless there is another major build difference, I don't see how r4745 would work and not r4748:

  • r4746 only affects platforms that build with the libav patches (Debian or Ubuntu)
  • r4747 only touches the OSX keyboard code
  • r4748 has nothing to do with the launcher GUI and is harmless

comment:3 Changed 6 years ago by Antoine Martin

Description: modified (diff)
Milestone: 0.11
Owner: changed from Antoine Martin to alas

Well then, I was wrong: I bisected it down to r4748 on win32.

The problem should be fixed by r4936, the changelog message should have read:
#467 fix launcher breakage caused indirectly by r4748 (except I fat fingered it.. so it's missing)

But, you can't test that revision alone, because I messed up... The changes to the launcher in r4935 (to ease debugging) needed more changes from the same files... which I only added later in r4937.

I wasn't happy with just fixing the cause of this particular startup failure: the error should have been more obvious and shown in the "Xpra-Launcher.exe.log" log file, so r4939 improves error handling in the launcher.


Anyway, works for me on both OSX and win32. Please confirm and close.

comment:4 Changed 6 years ago by alas

Resolution: fixed
Status: newclosed

As of r4940 the Launcher works as expected on both win and osx for me as well. Closing.

Note: See TracTickets for help on using tickets.