xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#470 closed defect (fixed)

osx sound: gstreamer library updates

Reported by: Antoine Martin Owned by: Smo
Priority: major Milestone: 0.11
Component: platforms Version:
Keywords: Cc:

Description

The current instructions (http://winswitch.org/dev/macosx.html) use the default stable jhbuild moduleset versions which are behind the latest 0.10 supported releases:

  • gstreamer-0.10.35
  • gst-plugins-base-0.10.35
  • gst-plugins-good-0.10.30

In the past, I was seeing some build errors with newer versions, but these have gone away (perhaps because I updated all of gstreamer at once).

Please confirm that this works and does not cause any sound regressions:

curl -O http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-0.10.36.tar.bz2
tar -jxf gstreamer-0.10.36.tar.bz2
cd gstreamer-0.10.36
./configure --prefix ${JHBUILD_PREFIX} --disable-tests
make && make install
cd ..

curl -O http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-0.10.36.tar.bz2
tar -jxf gst-plugins-base-0.10.36.tar.bz2
cd gst-plugins-base-0.10.36
./configure --prefix ${JHBUILD_PREFIX} --disable-tests
make && make install
cd ..

curl -O http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-0.10.31.tar.bz2
tar -jxf gst-plugins-good-0.10.31.tar.bz2
cd gst-plugins-good-0.10.31
./configure --prefix ${JHBUILD_PREFIX}
make && make install
cd ..

curl -O http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-0.10.23.tar.bz2
tar -jxf gst-plugins-bad-0.10.23.tar.bz2
cd gst-plugins-bad-0.10.23
./configure --prefix ${JHBUILD_PREFIX}
make && make install
cd ..

curl -O http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-0.10.19.tar.bz2
tar -jxf gst-plugins-ugly-0.10.19.tar.bz2
cd gst-plugins-ugly-0.10.19
./configure --prefix ${JHBUILD_PREFIX}
make && make install
cd ..

It is probably a good idea to remove all previous gstreamer libraries first, to ensure the new one get used and the two aren't mixed.

You will need r4916 to avoid errors like these:

(gst-plugin-scanner:89832): GStreamer-WARNING **: Failed to load plugin '/Users/MacAdmin/gtk/inst/lib/gstreamer-0.10/libgstsdl.so': \
    dlopen(/Users/MacAdmin/gtk/inst/lib/gstreamer-0.10/libgstsdl.so, 2): \
        Library not loaded: @executable_path/../Resources/lib/libgstpbutils-0.10.0.dylib
  Referenced from: /Users/MacAdmin/Desktop/Xpra.app/Contents/Resources/lib/libgstaudio-0.10.0.dylib
  Reason: image not found

We should probably submit those as updates to the gtk-osx gstreamer moduleset.
And/or maybe also update the build instructions to use modulesets we can easily maintain rather than hundreds of almost identical lines of ./configure && make && make install (which is what modulesets do)

Change History (2)

comment:1 Changed 6 years ago by Smo

Was able to install these new libraries with a few issues on my build system

gstreamer and some plugins were unable to build for me without

--host=i386-apple-darwin --build=i386-apple-darwin

appended to the configure line

I was having issues building gstreamer at first and I found a hint from macports.org
https://trac.macports.org/browser/trunk/dports/gnome/gstreamer010/Portfile

--disable-introspection

Appending this to the configure line allows it to continue. Previously I let it run the process for over an hour and a half an eventually ran out of memory.

comment:2 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Good, we'll have to include this info in a future wikification of the build instructions, or preferably using modulesets.

r4917 has the backport for v0.10.x - so closing. Feel free to re-open if there are any osx sound gstreamer problems due to this upgrade.

Note: See TracTickets for help on using tickets.