xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#480 closed defect (fixed)

strange warning message on windows using opengl on nvidia GTX 670

Reported by: aradtech Owned by: aradtech
Priority: minor Milestone: 0.11
Component: client Version: trunk
Keywords: Cc:

Description (last modified by Antoine Martin)

Windows 7 64 Nvidia GTX 670 Latest drivers

2013-12-19 17:48:17,118 src 8246 type 8251 id 20084 severity 9148 length 119 message \
    Texture state usage warning: Waste of memory: Texture 0 has mipmaps, while its min filter is inconsistent with mipmaps.
2013-12-19 17:48:17,132 src 8246 type 8251 id 20084 severity 9148 length 119 message \
    Texture state usage warning: Waste of memory: Texture 0 has mipmaps, while its min filter is inconsistent with mipmaps.

is repeated over and over in console window.

Attachments (3)

xpra-error.txt (5.2 KB) - added by aradtech 6 years ago.
nvidia-dumbmipmapwarning.patch (1.1 KB) - added by Antoine Martin 6 years ago.
try to avoid the mipmap warning by explicitly telling nvidia we don't use mipmaps
nvidia-dumbmipmapwarning-v2.patch (2.2 KB) - added by Antoine Martin 6 years ago.
updated patch ensuring we use the same texture identifier

Download all attachments as: .zip

Change History (14)

Changed 6 years ago by aradtech

Attachment: xpra-error.txt added

comment:1 Changed 6 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to Antoine Martin
Status: newassigned

According to this: https://qt.gitorious.org/qt/qtdeclarative/commit/4fa67b9ef3201214db0b7e6d61288faa33d6ea8d, it is a bogus warning message flood on nVidia driver with the KHR_debug extension active - nVidia seem unwilling to fix it in the driver.

We can probably apply the same fix here.

Changed 6 years ago by Antoine Martin

try to avoid the mipmap warning by explicitly telling nvidia we don't use mipmaps

comment:2 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to aradtech
Status: assignednew

Does the attachment/ticket/480/nvidia-dumbmipmapwarning.patch help?

With r5010 and later, does this make the warning disappear? (patch not needed then)

set XPRA_OPENGL_DEBUG=0
xpra_cmd attach ...

comment:3 Changed 6 years ago by aradtech

set XPRA_OPENGL_DEBUG=0 still have warning using r5016

comment:4 Changed 6 years ago by aradtech

Warning still shows with patch applied on r5153.

comment:5 Changed 6 years ago by Antoine Martin

Damn, all this unnecessary logging will slow us down and may cause/hide other problems.

Please try the updated patch. If this still does not solve the problem, please attach the full client log output both with XPRA_OPENGL_DEBUG=0 and with XPRA_OPENGL_DEBUG=1.

Changed 6 years ago by Antoine Martin

updated patch ensuring we use the same texture identifier

comment:6 Changed 6 years ago by aradtech

That patch fix's the problem :) Good work !

comment:7 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Thanks! Merged in r5158, will backport.

comment:8 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: closedreopened

Grrr. Causes GL errors on Fedora 20 in gl_window_backing.py at line 256: invalid value

Possibly because the GL driver doesn't like the first parameter: GL_TEXTURE_RECTANGLE_ARB? The spec doesn't list it as being a valid argument... Just because it works on win32 doesn't mean it's right!

comment:9 Changed 6 years ago by Antoine Martin

Status: reopenednew

r5166 uses GL_RECTANGLE_2D instead and works with mesa (tested in a Fedora 20 virtual machine)

Please check that it doesn't cause any regressions on win32: that GL is enabled, that the warning does not re-appear and that it still displays correctly.

Backport for v0.10.x is in r5170.

Last edited 6 years ago by Antoine Martin (previous) (diff)

comment:10 Changed 6 years ago by aradtech

Version 5178 Tested on Windows with opengl , no messages showing and all seems to be working well.

comment:11 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Thanks - closing again.

Note: See TracTickets for help on using tickets.