xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#497 closed defect (fixed)

Xpra-Launcher not starting (Code 255), xpra_cmd.exe works.

Reported by: drag0on Owned by: Antoine Martin
Priority: major Milestone:
Component: client Version:
Keywords: Cc:

Description

System:
Windows 8.1 no special configuration (ie Windows Firewall, Windows Defender and Drivers)
Lenovo Touch U430

I have nothing else to report as I tried to add the debugger but only got info that the process does exit with exit code 255.
This problem seems to be there on all versions I tested from https://www.xpra.org/dists/windows/

What is going on? What else should I do? Is there a debugging binary I can try to use?

Change History (4)

comment:1 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to Antoine Martin
Status: newassigned

Confirmed, you can help us by figuring out when this regression occurred, it certainly used to work before. This only affects Vista onwards, and is probably related to file write access somewhere.

comment:2 Changed 6 years ago by Antoine Martin

Note to drag0on: you can't have tried that many versions, I went far back based on the assumption that you had:

So the problem appeared between in the 0.10.x branch between r4669 and r4827 (not many changesets in that branch)

comment:3 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Bisecting:

This is yet another bug caused by FreeBSD compatibility (see #420).
The fix is in r5196 for trunk and r5199 for v0.10.x branch.

I have rebuilt 0.10.12 with this patch on top and uploaded it:
http://xpra.org/dists/windows/Xpra_Setup_0.10.12-r5199.exe

Closing - let me know if you still have problems.

comment:4 Changed 6 years ago by drag0on

Wow I was pretty sure that I tried Xpra_Setup_0.10.0-r4168.exe as it is in my Downloads folder, but after trying again you are right and this version is working. The given installer (Xpra_Setup_0.10.12-r5199.exe) is also working fine, thank you

Note: See TracTickets for help on using tickets.