xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#528 closed defect (fixed)

Launcher failing with 0.12.0

Reported by: J. Max Mena Owned by: J. Max Mena
Priority: major Milestone:
Component: client Version: trunk
Keywords: client windows osx Cc:

Description (last modified by Antoine Martin)

When using the Xpra launcher r5692 and newer on OSX and Windows, and server version r5711, the launcher won't connect and just says 'NoneType' object has no atttribute 'start'

However, launching from command line works as expected.

Change History (6)

comment:1 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to Antoine Martin
Status: newassigned

Confirmed, happens on the second attempt if the first one failed, it comes up with the alert box telling you there are log messages to read, the file it points to contains:

2014-03-07 07:29:35,887 client error
Traceback (most recent call last):
  File "client_launcher.py", line 530, in do_start_XpraClient
  File "xpra\client\gtk_base\gtk_client_base.pyc", line 51, in run
  File "xpra\client\ui_client_base.pyc", line 302, in run
AttributeError: 'NoneType' object has no attribute 'start'

comment:2 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to J. Max Mena
Status: assignednew

This was caused by r5674, fixed in r5715, we now need to initialize the UI separately.

comment:3 Changed 6 years ago by J. Max Mena

Getting a new error in the launcher for r5750 and r5773:

"too late to set modules, the helper is already intialized"

Once again, the command line works

comment:4 Changed 6 years ago by Antoine Martin

Description: modified (diff)

This was fixed as per comment:3, but in between then and now it got broken again by r5741: we now need to init the video helper, which means that we must also clean it after use. r5774 fixes that.


There were still some messages that went to the automatic py2exe log capture and caused the dreaded alert box to show up on exit. r5776 + r5777 + r5778 refactor all the launch code, for all platforms. Tested on win32, osx and Linux.

comment:5 Changed 6 years ago by J. Max Mena

r5801 launcher works for both Windows and OSX.

comment:6 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.