xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#552 closed defect (fixed)

0.12.1: switching to RGB encoding from tray do not work

Reported by: onlyjob Owned by: onlyjob
Priority: major Milestone:
Component: encodings Version: 0.12.x
Keywords: Cc:

Description (last modified by Antoine Martin)

With 0.12.1 RGB encoding does not work any more. First I've noticed it when I've chosen PNG/greyscsale, then switched to RGB and noticed that windows remained colourless. Then I tried to attach with "--encoding=raw" and got error "invalid encoding: raw".

Change History (6)

comment:1 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to onlyjob

There has never been a raw encoding, my guess is that you probably want rgb.

See:

man xpra

or:

xpra attach --encoding=help


I've chosen PNG/greyscsale, then switched to RAW and noticed that windows remained colourless


Now that would be a bug. Did you switch from the tray?
Does it work if you switch from the command line?

Last edited 6 years ago by Antoine Martin (previous) (diff)

comment:2 Changed 6 years ago by onlyjob

Yes switching to rgb do not work from tray. Very easy to reproduce.

Obviously I forgotten encoding name (sorry). I tried again with --encoding=rgb and it worked on attach.
I know how to *choose* encoding with --encoding given on attach but I don't know how to *switch* encoding from command line for active session (is it even possible?).

Last edited 6 years ago by onlyjob (previous) (diff)

comment:3 Changed 6 years ago by onlyjob

Summary: 0.12.1: RAW encoding do not work0.12.1: switching to RGB encoding from tray do not work

comment:4 Changed 6 years ago by Antoine Martin

Description: modified (diff)
Priority: blockermajor

Fixed in r5930, backport to v0.12.x branch in r5931.

That was caused by the fact that "rgb" is a pseudo encoding, encompassing both "rgb24" (for regular pixels) and "rgb32" for transparent windows. The validation was too strict.

I am lowering the priority of this ticket (and not rushing a new stable release) as all the other encodings work as expected and a workaround exists (use the command line rather than the tray).


I don't know how to *switch* encoding from command line for active session


That was a surprising omission from the "xpra control" interface, rectified in r5934:

xpra control :10 encoding rgb


Can I close this ticket?

comment:5 in reply to:  4 Changed 6 years ago by onlyjob

Replying to totaam:

Fixed in r5930, backport to v0.12.x branch in r5931.


I'm unable to confirm that r5931 fixes it -- I applied it to 0.12.1 but the problem is still there...


I am lowering the priority of this ticket (and not rushing a new stable release) as all the other encodings work as expected and a workaround exists (use the command line rather than the tray).


Agreed.

I don't know how to *switch* encoding from command line for active session


That was a surprising omission from the "xpra control" interface, rectified in r5934:

xpra control :10 encoding rgb


Cool! :)

Can I close this ticket?


Let's make sure it fixed please. I'll test within hours so I hope it won't take long. Thanks.

comment:6 Changed 6 years ago by onlyjob

Resolution: fixed
Status: newclosed

Fixed in 0.12.2, thanks.

Note: See TracTickets for help on using tickets.