xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#557 closed defect (fixed)

qt5 applications don't notice they've been moved? their menus are misplaced

Reported by: Antoine Martin Owned by: rikky
Priority: critical Milestone: 0.13
Component: server Version: 0.12.x
Keywords: Cc: rikki

Description

Split from #556.

The menus show up where they would be if the parent window was still where it was first mapped (and without its window frame), as if the location where the client actually placed the window got completely ignored. Or if the coordinates are relative to the parent window rather than relative to the root window!?

The only qt5 application I have with menus is the qt script debugger, which can be launched from qstetrix. I hope I can find something easier to test.

Change History (2)

comment:1 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to rikky

Bisection "fun":

No idea why the bug was intermittent, but r5766 is definitely the problematic commit.

This was caused by the work in trying to limit how many times we send "ConfigureNotify" to windows for #532, which turned out to be a buggy application (handbrake). So we don't bother trying so hard to play nice (which still did not solve the buggy application behaviour anyway), and r6061 undoes r5766 and some later related commits which became redundant.

Works for me, @rikki: can you confirm?

comment:2 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Was confirmed as fixed in #556, closing.

Note: See TracTickets for help on using tickets.