xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#566 closed defect (fixed)

meta keys scrambled, OSX/Linux

Reported by: Troy Cauble Owned by: Troy Cauble
Priority: minor Milestone:
Component: client Version: 0.12.x
Keywords: Cc:

Description

OSX Xpra Client, Ubuntu Xpra Server & calibre application.

In this configuration, the Linux app used to use Linux meta keys -- ctrl-C, ctrl-V, ctrl-A, etc. Recently some of the OSX meta keys work instead -- command-C/V/A, etc. I don't know if this was by choice or accident.

If this is on purpose to make apps feel like client apps, I think that is a mistake. Many applications explicitly display their meta keys as hints in menus 'Ctrl-P'. Also, some apps use complex meta combinations that may get lost in translation.

Also, I am currently unable to do disjoint selections in lists -- select, then ctrl-select (or command-select).

Change History (8)

comment:1 Changed 6 years ago by Troy Cauble

Also, ctrl-Q to close the application is intercepted by Xpra and Xpra closes.

Also, swapping ctrl for command doesn't work at all for command line apps and curses apps -- VIM, EMACS, shell navigation and exit, etc.

Last edited 6 years ago by Troy Cauble (previous) (diff)

comment:2 Changed 6 years ago by Antoine Martin

Resolution: invalid
Status: newclosed

That's not a bug I am afraid, and not a new thing either (present in v0.11), see: #456

There is also an option in the menu to disable the swapping (we could add a command line option for it).

comment:3 Changed 6 years ago by Troy Cauble

Component: androidclient
Priority: majorminor
Resolution: invalid
Status: closedreopened

OK, great!

  1. A command line option would be appreciated.
  1. It won't bother me anymore since I'll turn off the swap, but I'll restate one item: With the swap on, you can't select multiple, non-adjacent items in a list. I suspect command-click -> ctrl-click is not being forwarded.

comment:4 Changed 6 years ago by Antoine Martin

I'll try to remember to add the command line option, as for the other one it sounds like a real bug, so I am moving it to: #567 (please add yourself to the CC list)

comment:5 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to Troy Cauble
Status: reopenednew

The command line option has been added in r6427: --no-swap-keys.

Note: you can also just place it in your ~/.xpra/xpra.conf or even /etc/xpra/xpra.conf to make it global:

echo "swap-keys=no" >> ~/.xpra/xpra.conf

Beta builds including this change (and much more) are available here:
osx beta area

If that works for you, please close this ticket.

comment:6 Changed 6 years ago by Troy Cauble

The command line option worked.
The config file change did not and produced Warning: invalid option: 'swap-keys'

comment:7 Changed 6 years ago by Antoine Martin

That was a typo, r6434 fixes that.

New beta build available in the same location.

comment:8 Changed 6 years ago by Troy Cauble

Resolution: fixed
Status: newclosed

Works for me.

Note: See TracTickets for help on using tickets.