xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#575 closed defect (fixed)

miss build/check of build.version and version attribute in hello message

Reported by: Benoit Gschwind Owned by: Benoit Gschwind
Priority: major Milestone: 0.13
Component: core Version: trunk
Keywords: Cc:

Description (last modified by Antoine Martin)

the variable is ill-formed within several point in code, I attached patch that resolve the issue.

the patch is on top of trunk @ 6539

Attachments (1)

0001-fix-error-in-hello-message-linked-to-build.version-a.patch (3.7 KB) - added by Benoit Gschwind 6 years ago.
patch that resolve the issue

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by Benoit Gschwind

patch that resolve the issue

comment:1 Changed 6 years ago by Antoine Martin

Description: modified (diff)
Milestone: 0.13
Owner: changed from Antoine Martin to Benoit Gschwind

Thanks for the fix!

  • merged the "mk" part in r6540, this makes perfect sense.
  • I've also removed the version info duplication (twice!) in r6541, instead of fixing the prefix in one of the redundant calls.
  • merged the code that looks for both the prefixed version (build.version and proxy.build.version) and the "legacy" one (version and proxy.version) in r6542. (that way, hopefully one day far into the future, we can drop the unprefixed one)
  • r6543 also re-adds proxy.version to the proxy's hello packet to remain backwards compatible with older clients

I believe this should now be OK and backwards compatible both ways?

Last edited 6 years ago by Antoine Martin (previous) (diff)

comment:2 Changed 6 years ago by Benoit Gschwind

Seems working here :)

Best regards

comment:3 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Thanks! Bug squashed.

comment:4 Changed 4 years ago by Antoine Martin

Description: modified (diff)
Note: See TracTickets for help on using tickets.