xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 5 years ago

#600 closed defect (fixed)

centos5: no attribute 'image_new_from_pixbuf'

Reported by: pyther Owned by: Antoine Martin
Priority: major Milestone: 0.14
Component: client Version: 0.13.x
Keywords: Cc:

Description

Building xpra for centos5 and ran into this issue when I tried to test.

$ xpra --opengl=no attach
xpra main exception: 'module' object has no attribute 'image_new_from_pixbuf'

Ticket #254 might be related to this problem.

Just reporting the bug, as the centos5 client is broken. I personally have no desire to run xpra under centos5.

Change History (2)

comment:1 Changed 5 years ago by Antoine Martin

Owner: changed from Antoine Martin to Antoine Martin
Status: newassigned

I rarely ever test centos5... I only fix it when someone complains that it has broken again. And seeing how long it had been broken this time around, it may be time to drop support for it.

But most of the fixes were easy enough so here they are:

  • r6795 + r6796: workaround missing image_new_from_pixbuf by re-implementing it if needed
  • r6798: don't error out if gtk<2.12 does not support setting window opacity
  • r6799: removes the use of absolute_import which is just not available in python24, and replaces it with a workaround (indirect import)
Last edited 5 years ago by Antoine Martin (previous) (diff)

comment:2 Changed 5 years ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Backported to v0.13.x branch in r6801. Tested OK, closing.

Note: See TracTickets for help on using tickets.