xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#652 closed defect (fixed)

lossy regions with "Raw RGB" encoding

Reported by: onlyjob Owned by: Antoine Martin
Priority: major Milestone:
Component: encodings Version: 0.14.x
Keywords: Cc:

Description

Just noticed that on 0.14.1 some windows' regions are lossy when "Raw RGB" encoding is chosen... I've spotted this on text on red background in Libreoffice Calc. PNG encodings seems to be OK as well as loseless WebP.

Change History (3)

comment:1 Changed 6 years ago by Antoine Martin

I'm glad you use rgb as encoding as you tend to hit bugs that are only possible with rgb encoding and that we missed because of that.

The problem here is that rgb is a virtual encoding, and depending on whether the window has any alpha and whether the client can actually show the alpha, we choose between rgb24 and rgb32. The checks wrongly decided that rgb was not supported as an encoding.. (because it isn't!) and used something else (dynamically chosen). Fixed in r7384. Will backport.

You can easily verify what gets used with (for "selection=" you need r7385 which is in 0.14.x for the next release):

xpra info | egrep "frame|encoding=|selection="

Last note: this was caused by changes that made encoding selection a lot faster.

Version 0, edited 6 years ago by Antoine Martin (next)

comment:2 in reply to:  1 Changed 6 years ago by onlyjob

Replying to totaam:

I'm glad you use rgb as encoding as you tend to hit bugs that are only possible with rgb encoding and that we missed because of that.


The pleasure is mine. :)

Fixed in r7384. Will backport.


Tested and confirmed as fixed. Thank you.

comment:3 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Backport in r7387. Closing.

Note: See TracTickets for help on using tickets.