xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#659 closed defect (worksforme)

connecting with a new client did not cause the existing client to disconnect cleanly, got connection lost instead

Reported by: Antoine Martin Owned by: alas
Priority: major Milestone: 0.15
Component: core Version: trunk
Keywords: Cc:

Description

Please confirm if this is reproducible.

I had used:

  • Fedora 20 server
  • windows client
  • new client was fedora 20 (might have been a local connection)

This causes the client to wrongly exit with an error code, and I believe maybe also the tray did not get cleaned up properly.

Change History (3)

comment:1 Changed 6 years ago by Antoine Martin

Very similar to #581.

comment:2 Changed 6 years ago by alas

I connected to a fedora 20 server (0.15.0-r7514) with an osx client (0.15.0-r7514)... then connected to the same session with a new client (windows 0.15.0-r7514).

OSX command line output:

2014-09-04 17:09:08,779 server requested disconnect: new client (this session does not allow sharing)
2014-09-04 17:09:09,016 Connection lost

I then went and re-connected with the OSX client and got the following output from the windows command line connection (note - I was not paying attention to sound, so that output was a surprise to me and I'm not sure what to make of it...):

2014-09-04 17:34:21,372 sound source pipeline error: Could not open resource for
 reading. / ..\..\..\..\..\Source\gst-plugins-good\sys\directsound\gstdirectsoun
dsink.c(501): gst_directsound_sink_prepare (): /GstPipeline:pipeline3/GstDirectS
oundSink:directsoundsink3
2014-09-04 17:34:21,381 push-buffer error: <enum GST_FLOW_WRONG_STATE of type Gs
tFlowReturn>
2014-09-04 17:34:21,384 stopping speaker because of error: push-buffer error: <e
num GST_FLOW_WRONG_STATE of type GstFlowReturn>
2014-09-04 17:42:46,440 server requested disconnect: new client (this session do
es not allow sharing)
2014-09-04 17:42:46,808 Connection lost

Looks like I'm getting the connection lost as well... which, as I recall, I have been seeing for a long time now... so I thought that was the expected message when a non-sharing session got passed from one client to another.

Let me know if there are any -d logs that might help.

comment:3 Changed 6 years ago by Antoine Martin

Resolution: worksforme
Status: newclosed

Looks fine: both log server requested disconnect: new client (this session does not allow sharing), closing.

Must have been a fluke or a different bug. We can re-open if we hit it again.

Note: See TracTickets for help on using tickets.