xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 5 years ago

#666 closed defect (fixed)

start-child drops command line arguments

Reported by: Antoine Martin Owned by: onlyjob
Priority: major Milestone: 0.15
Component: core Version: 0.14.x
Keywords: Cc: [email protected]

Description

Example:

xpra start ssh:localhost:10 --start-child="xterm -bg blue"

Should start a blue xterm... but instead we find:

ssh -T localhost sh -c \
    'xpra initenv >> /dev/null 2>&1 || echo "Warning: xpra server does not support initenv" 1>&2; \
     ~/.xpra/run-xpra _proxy_start :10 '--start-child=xterm -bg blue' --dpi=96'
sh -c xpra initenv >> /dev/null 2>&1 || echo "Warning: xpra server does not support initenv" 1>&2; \
    ~/.xpra/run-xpra _proxy_start :10 --start-child=xterm -bg blue --dpi=96
/bin/python /usr/bin/xpra _proxy_start :10 --start-child=xterm
/bin/python /usr/bin/xpra start :10 --start-child=xterm

The quotes are correct when we call ssh, but by the time sh is run, the quotes have been stripped?

Related to #632.

Change History (6)

comment:1 Changed 5 years ago by onlyjob

Cc: [email protected] added

comment:2 Changed 5 years ago by Antoine Martin

Owner: changed from Antoine Martin to onlyjob

Works for me with r7520.

I've tested:

  • the command in this ticket
  • xpra start ssh:localhost:44 --start-child="xterm" --start-child="xeyes"
  • as above but with a start-child entry in xpra.conf (checking for #632 regressions)

@onlyjob: can you break it? Do you think this is suitable for v0.14.x?

comment:3 Changed 5 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Backport for v0.14.x was in r7529. Closing.

comment:4 Changed 5 years ago by Antoine Martin

Resolution: fixed
Status: closedreopened

Apparently, this may cause problems with tcsh: Ambiguous output redirect

comment:5 Changed 5 years ago by Antoine Martin

This should be fixed in r7912. Needs backporting.
Keeping this open until then to make sure we don't somehow break / miss something.

comment:6 Changed 5 years ago by Antoine Martin

Resolution: fixed
Status: reopenedclosed

Backported in r7926.

Note: See TracTickets for help on using tickets.