xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#667 closed defect (invalid)

server-side warning: CompositeHelper::shm-handle after class was initialised

Reported by: onlyjob Owned by: onlyjob
Priority: major Milestone:
Component: server Version: 0.14.x
Keywords: Cc:

Description (last modified by Antoine Martin)

On 0.14.4 and I've noticed that mouse cursor is not changing shape when hovered on text fields, borders etc. I've tried re-attaching several times and only on fifth attempt cursor forwarding worked. I've checked server log and found the following errors that appear on every xpra upgrade:

/usr/lib/python2.7/dist-packages/gobject/__init__.py:115: Warning: \
    Attempt to add property xpra+x11+gtk_x11+composite+CompositeHelper::shm-handle after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))

Change History (5)

comment:1 Changed 6 years ago by Antoine Martin

Description: modified (diff)

The mouse cursor not changing shape sounds like it could be related to the recently fixed bug which was causing full server crashes on Ubuntu 12.04: r7457. (I fixed the crash - noting that I did not really understand why the cursor call failed...)

More information should be available in the log with -d cursor.

As for the CompositeHelper warning, this class has not changed (at least not substantially, or anything related to gobject) in years. Why is this only showing up now is good question.
More than likely, this is a completely different issue.

comment:2 Changed 6 years ago by onlyjob

This is very confusing but I can't reproduce problem with cursor shape any more. Nothing seems to change which is quite strange...

As for CompositeHelper warning I am not sure when it started to happen. I had no reason to check server log for a while...

comment:3 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to onlyjob

A good way to test cursor issues (apart from including -d cursor output):

  • test_all_cursors.py allows you to choose a cursor from a list to verify it gets forwarded correctly
  • test_custom_cursor.py paints a custom cursor with flashy colors, to verify colors are also forwarded correctly

Both work fine here with 0.14.x and trunk.


As for the server gobject warning, I am unable to reproduce it on Debian Wheezy with the xpra.org deb package of 0.14.4 or with a clean source install from trunk.

xpra start --no-daemon --start-child=xterm :10

I attach:

xpra attach --no-mmap

Then upgrade it:

xpra upgrade --no-daemon

The warning is nowhere to be seen in any of those sessions.

comment:4 Changed 6 years ago by onlyjob

I see... After countless session restarts I did not see any cursor issues any more. Perhaps it could be a temporary unresponsive application due to heavy IO?
Anyway please feel free to close this ticket unless you want to keep it open to track warning. I have a mix of packages from "wheezy" and from "testing" so something from "jessie" might have caused this. I'll report if I manage to find more details. Thanks.

comment:5 Changed 6 years ago by Antoine Martin

Resolution: invalid
Status: newclosed
Summary: server-side errorsserver-side warning: CompositeHelper::shm-handle after class was initialised

OK, closing. If anyone ever hits this warning anywhere, please re-open.

Note: See TracTickets for help on using tickets.