xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 5 years ago

#672 closed defect (fixed)

wrong color mapping of application window icons with plain rgb encoding (png disabled)

Reported by: sschnitzer Owned by: sschnitzer
Priority: major Milestone:
Component: client Version: trunk
Keywords: Cc:

Description

Hi.

The application icons (displayed in the task bar and on the top left of windows) have wrong color mapping if compression is disabled.
The attached file shows the top left corner of a "konqueror" window. The left part depicts the icon of a xpra-redirect window, the right part of a native one. I guess that the red and blue channels got accidentially swapped.
My setup:
Xpra 0.14.4
Linux server, Windows 7 client.
Client xpra.conf (only altered options):

encodings = rgb
compressors = none

Without these options, the window icons are correct.

Best,
Stephan

Attachments (2)

xpra_icons.png (1.2 KB) - added by sschnitzer 5 years ago.
konqueror application icons (wrong and correct side-by-side)
xpra_test.png (923 bytes) - added by sschnitzer 5 years ago.
Screenshot of test_window_icon_colors.py

Download all attachments as: .zip

Change History (11)

Changed 5 years ago by sschnitzer

Attachment: xpra_icons.png added

konqueror application icons (wrong and correct side-by-side)

comment:1 Changed 5 years ago by Antoine Martin

Owner: changed from Antoine Martin to sschnitzer

I've added a test system tray with clear red, green and blue colours to make it easier to test in r7550.

I am unable to reproduce this bug.
Can you be a bit more specific about which "Linux Server" you have used?

Are you sure that compressors = none makes any difference? (try -z 1 on command line to override your config)

comment:2 Changed 5 years ago by sschnitzer

The system tray works fine, your test program produces the same result with and without xpra.

Hover, the actual problem is the icon displayed on the top left of windows. The correct term seems to be "title bar", here is picture:
http://en.wikipedia.org/wiki/Title_bar
The same icon is used for the the "task bar":
http://en.wikipedia.org/wiki/Taskbar

You are right, that compressors does not matter. I just verified:
encodings = rgb (wrong colors)
encodings = all (correct colors)

Server is Centos 7 having the respective rpm packages from the xpra.org download directory installed.

comment:3 Changed 5 years ago by Antoine Martin

Owner: changed from sschnitzer to totaamsschnitzer

Sorry about that, your description was perfectly clear but I somehow managed to get confused about what I was doing!

r7576 fixes this (will backport to v0.14.x) and r7577 adds a simple test application which makes it easy to see what is going on (same code as the tray app)

I think this bug is very old, but we never noticed because until now png was always available and was used ahead of rgb for window icons.

Does this work for you? Can I close?

comment:4 Changed 5 years ago by Antoine Martin

Owner: changed from totaamsschnitzer to sschnitzer

comment:5 Changed 5 years ago by Antoine Martin

Summary: Wrong color mapping of application icons if compression disabledwrong color mapping of application window icons with plain rgb encoding (png disabled)

(edit title)

comment:6 Changed 5 years ago by sschnitzer

I applied r7576 to the xpra server code, only. Right?
Unfortunately, this did not solve the issue.
I attach a screenshot of r7577.

Changed 5 years ago by sschnitzer

Attachment: xpra_test.png added

Screenshot of test_window_icon_colors.py

comment:7 Changed 5 years ago by Antoine Martin

No, r7576 is a client-side fix, you can find a beta win32 build with the fix here: http://xpra.org/beta/.

comment:8 Changed 5 years ago by sschnitzer

Thanks for the extra win32 build.
Problem solved!

comment:9 Changed 5 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Backport to v0.14.x in r7579. (non-trivial)

Closing.

Note: See TracTickets for help on using tickets.