xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#679 closed enhancement (fixed)

opengl improvements: double buffering, limited repaints, paint state

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: major Milestone: 0.16
Component: client Version: trunk
Keywords: Cc:

Description (last modified by Antoine Martin)

See also ticket:640#comment:3.

At the moment, only win32 uses double-buffering by default.
Is it required? Useful? The PBO is a bit like our own double buffering already.
Does double buffering limit the number of paints we can do per second because of the synchronization that happens when we swap_buffers? (if there is any!)
This can also cause problems if we have many windows: they will all consume synchronization time. Or will they? See Swap buffer synchronization and Using SwapBuffers() with multiple OpenGL canvases and vertical sync?

This needs testing with:

XPRA_OPENGL_DOUBLE_BUFFERED=0

And maybe a dedicated test app to trigger the paint refresh pattern needed for testing. (many windows? fast refresh? hard!)

Same for Linux, do we want to enable double buffering there?
Does it work reliably? (works here)

Also, when not using double buffering, we can optimize repaints to only paste the fbo contents on the area of the window that needs updating instead of the whole window.

As per http://www.mesa3d.org/brianp/sig97/perfopt.htm: SwapBuffer? calls and graphics pipe blocking: On systems with 3-D graphics hardware the SwapBuffers? call is synchronized to the monitor's vertical retrace. Input to the OpenGL command queue may be blocked until the buffer swap has completed. Therefore, don't put more OpenGL calls immediately after SwapBuffers?. Instead, put application computation instructions which can overlap with the buffer swap delay.
See also http://www.opengl.org/wiki/Swap_Interval
We should try to ensure we don't make any GL calls after swap_buffers.
For example, the whole set_rgb_paint_state / unset_rgb_paint_state logic should be changed to be done on-demand before each paint rather than assuming a specific state is the default. There is also a glClear there, not sure what to do with it: it doesn't really do anything, but I can only find conflicting information on the performance implications.

Also, we want zerocopy upload for video encodings, especially dec_avcodec2, see #717 - currently disabled because avcodec buffers are not thread safe?

We probably should re-probe the max texture size check when the screen is resized?

Change History (12)

comment:1 Changed 5 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to Antoine Martin
Status: newassigned
Summary: opengl improvements: double buffering, limited repaintsopengl improvements: double buffering, limited repaints, paint state

comment:2 Changed 5 years ago by Antoine Martin

Description: modified (diff)

Improvements:

  • r7600 + r7608: only repaints what is needed in single-buffer mode
  • r7601: paint debugging via XPRA_OPENGL_PAINT_BOX env var
  • r7602: adds GL_PERSPECTIVE_CORRECTION_HINT hint
  • r7603: removes the glClear after swap_buffers

No matter how many small glxgears window I start, I seem to only get ~60fps, which is my monitor refresh rate... So we are capped.

Whilst we're here, it would be good to deal with #478 too.

Last edited 5 years ago by Antoine Martin (previous) (diff)

comment:3 Changed 5 years ago by Antoine Martin

r7600 caused #693: bug with scaling, which is fixed in r7804.

Last edited 5 years ago by Antoine Martin (previous) (diff)

comment:4 Changed 5 years ago by Antoine Martin

Description: modified (diff)

#717: bug caused by old versions of pyopengl found in Fedora 20..

comment:5 Changed 5 years ago by Antoine Martin

See also: #760, #792

Last edited 5 years ago by Antoine Martin (previous) (diff)

comment:6 Changed 5 years ago by Antoine Martin

Milestone: 0.150.16

Re-scheduling.

comment:7 Changed 5 years ago by Antoine Martin

Description: modified (diff)

comment:8 Changed 4 years ago by Antoine Martin

Double-buffering seems to work on Linux see ticket:760#comment:22, but on OSX this hides the box paint feature.

comment:9 Changed 4 years ago by Antoine Martin

A lot of work was completed in #792.

Which only leaves the cleanup of the paint state logic.

comment:10 Changed 4 years ago by Antoine Martin

I've just hit this error by starting a new command via the control channel very early and / or changing focus as it appeared:

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/client/gl/gtk2/gl_window_backing.py", line 39, in gl_expose_event
    self.gl_init()
  File "/usr/lib64/python2.7/site-packages/xpra/client/gl/gl_window_backing_base.py", line 396, in gl_init
    glClear(GL_COLOR_BUFFER_BIT)
  File "/usr/lib/python2.7/site-packages/OpenGL/platform/baseplatform.py", line 402, in __call__
    return self( *args, **named )
  File "errorchecker.pyx", line 53, in OpenGL_accelerate.errorchecker._ErrorChecker.glCheckError (src/errorchecker.c:1218)
OpenGL.error.GLError: GLError(
	err = 1286,
	description = 'invalid framebuffer operation',
	baseOperation = glClear,
	cArguments = (GL_COLOR_BUFFER_BIT,)
)
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/client/gl/gtk2/gl_window_backing.py", line 39, in gl_expose_event
    self.gl_init()
  File "/usr/lib64/python2.7/site-packages/xpra/client/gl/gl_window_backing_base.py", line 396, in gl_init
    glClear(GL_COLOR_BUFFER_BIT)
  File "errorchecker.pyx", line 53, in OpenGL_accelerate.errorchecker._ErrorChecker.glCheckError (src/errorchecker.c:1218)
OpenGL.error.GLError: GLError(
	err = 1286,
	description = 'invalid framebuffer operation',
	baseOperation = glClear,
	cArguments = (GL_COLOR_BUFFER_BIT,)
)

Maybe the expose event fired before we have a proper gl context to use for painting? r9871 should fix that.

Last edited 4 years ago by Antoine Martin (previous) (diff)

comment:11 Changed 4 years ago by Antoine Martin

Minor enhancement / fix: see r10172.

comment:12 Changed 4 years ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Closing:

  • not doing the change to the paint state logic, the YUV one is the hot path
  • more testing can be done as part of #792
  • double-buffering: meh, it ain't broke
Last edited 4 years ago by Antoine Martin (previous) (diff)
Note: See TracTickets for help on using tickets.