xpra icon
Bug tracker and wiki

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#69 closed defect (fixed)

xpra doesn't connect, gives errors

Reported by: pmarek Owned by: Antoine Martin
Priority: minor Milestone: 0.0.7.x
Component: client Version: 0.0.7.34
Keywords: Cc:

Description

$ xpra attach ssh:host-with-ssh-tunnel:65 --auto-refresh-delay=5 --no-keyboard-sync
using dbusnotify: <class 'dbus.proxies.Interface'>(org.freedesktop.Notifications)
Attached (press Control-C to detach)
Traceback (most recent call last):
  File "/usr/lib/xpra/xpra/platform/client_extras_base.py", line 311, in populate_table
    settimedeltastr(self.session_started_label, self.client.server_start_time)
AttributeError: 'ClientExtras' object has no attribute 'session_started_label'

^C

I killed it via CTRL-C here; another try immediately after did work.

Built on winswitch.org by root. 2012-01-12
(svn revision 431 with 0 local changes)

Change History (5)

comment:1 Changed 8 years ago by Antoine Martin

Owner: changed from Antoine Martin to Antoine Martin
Status: newaccepted

This must have happened when you clicked to get the session statistics window, right? Temporary workaround is to wait for the connection to be made before clicking on it.

There is a race there if you bring up this window before the client has connected to the server, will fix this asap - and probably make a new release with the fix.

comment:2 Changed 8 years ago by Antoine Martin

r436 removes this race, can I close this?

comment:3 Changed 8 years ago by pmarek

I guess so ... after it's a race I cannot reproduce it anyway.

comment:4 Changed 8 years ago by Antoine Martin

Resolution: fixed
Status: acceptedclosed

comment:5 Changed 8 years ago by Antoine Martin

Milestone: 0.0.7.x
Version: 0.0.7.34
Note: See TracTickets for help on using tickets.