xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 5 years ago

#701 closed defect (fixed)

xpra launcher causes new menus to show in global menu bar on osx

Reported by: Antoine Martin Owned by: alas
Priority: major Milestone: 0.15
Component: platforms Version: trunk
Keywords: osx menu Cc:

Description (last modified by Antoine Martin)

Launching from the command line works fine.

We're probably initializing something twice.

See screenshot:

shows the double apple bug

Attachments (2)

double-apple.png (53.2 KB) - added by Antoine Martin 5 years ago.
shows the double apple bug
osx-double-menus.png (63.0 KB) - added by Antoine Martin 5 years ago.
restarting the session from the launcher doubles the menus every time!

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by Antoine Martin

Attachment: double-apple.png added

shows the double apple bug

comment:1 Changed 5 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to Antoine Martin
Status: newassigned

comment:2 Changed 5 years ago by Nick Centanni

Priority: minormajor

Changed 5 years ago by Antoine Martin

Attachment: osx-double-menus.png added

restarting the session from the launcher doubles the menus every time!

comment:3 Changed 5 years ago by Antoine Martin

Owner: changed from Antoine Martin to alas
Status: assignednew
Summary: xpra launcher causes a second "apple" menu to show in global menu bar on osxxpra launcher causes new menus to show in global menu bar on osx

I couldn't reproduce the original description of this bug, only a slightly different one (but also much worse):
restarting the session from the launcher doubles the menus every time!

I got this by connecting from the launcher, sending a SIGINT (via control-c) to return to the launcher and connect to the same server again: all the menus were then re-added.

r8548 fixes this (backport in r8549).

@afarr: this is just a FYI, please close unless you feel like finding a way to break it.

comment:4 Changed 5 years ago by alas

Resolution: fixed
Status: newclosed

Not sure how you sent a control-c command while connected via the launcher... but I tried connecting via GUI launcher and quitting and re-connecting... and I tried from an osx terminal with a control-c then reconnect... and I tried again with the GUI launcher using the tray icons to right-click and quit. I couldn't get any extra apple icons or menu items no matter which way I tried.

(My session info is still displaying scrambled on my osx build, but I think it was 0.15.0 r8640 against fedora 20 0.15.0 r8606.)

Closing.

Note: See TracTickets for help on using tickets.