xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#710 closed defect (invalid)

Debian packaging is broken in 0.15

Reported by: Antoine Martin Owned by: onlyjob
Priority: critical Milestone: 0.15
Component: packaging Version: trunk
Keywords: debian Cc: onlyjob@…

Description

Nothing has changed in the debian directory for quite some time and things were still building fine last week (I still have deb packages I made).

But when I tried yesterday:

dh binary --with python2 --with quilt
   dh_testroot
   dh_prep
   dh_install
dh_install: xpra missing files (usr/lib/*/*/xpra), aborting
debian/rules:10: recipe for target 'binary' failed
make: *** [binary] Error 2
dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2
debuild: fatal error at line 1364:
dpkg-buildpackage -rfakeroot -D -us -uc -b failed
mv: cannot stat ‘/usr/src/tmp/BUILDROOT/Xpra/trunk/*deb’: No such file or directory
mv: cannot stat ‘/usr/src/tmp/BUILDROOT/Xpra/trunk/*changes’: No such file or directory

It doesn't even try to build anything and fails with the cryptic messages above.

If I remove the BUILDOPTS and the overrides for build and install, it does actually build something, but then I get this error instead afterwards:

dh_install: xpra missing files (usr/lib/*/*/xpra), aborting
debian/rules:10: recipe for target 'binary' failed

Lots of time wasted, still stuck. Please help!

Change History (4)

comment:1 Changed 6 years ago by onlyjob

So far I could not reproduce this problem by building manually from trunk (i.e. copy src folder to temporary directory, add "debian" to it, add patches to debian/patches/series file, etc.).

Please try to build with export DH_VERBOSE=1 added to the beginning of debian/rules file. It may also be helpful to add -v argument to dh_auto_build and to dh_auto_install.

Also I would add --with-verbose to BUILDOPTS in order to increase (upstream) build verbosity.

comment:2 Changed 6 years ago by onlyjob

Cc: onlyjob@… added

comment:3 Changed 6 years ago by Antoine Martin

Resolution: invalid
Status: newclosed

Sorry to have wasted your time, the problem was at my end as usual (in the horrible build scripts that I use): the build scripts needed to take out BUILDOPTS for Ubuntu which does not support xdummy, and because of a scripting mistake, it ended up taking it out in all cases.. and that's what was causing the debuild command to fail in this odd manner.

I've changed it to just replace with-Xdummy with without-Xdummy in the rules file (for Ubuntu only), and that works fine in all cases now.

comment:4 Changed 6 years ago by onlyjob

No worries, I'm glad that you've found (and fixed) the problem.

Note: See TracTickets for help on using tickets.