xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#711 closed defect (fixed)

extremely slow server - takes seconds to process events

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: blocker Milestone: 0.15
Component: server Version: trunk
Keywords: Cc:

Description

Only seems to occur if:

  • using trunk (0.14.x not affected)
  • not using --no-daemon
  • not for all users (maybe sudo or something is required to trigger it)

The -d all log shows the server is stuck waiting for the main loop to run. Eventually, a ping packet request is scheduled via a timer and everything flows again!?
ie:

2014-10-10 12:10:30,892 will process ui packet focus
2014-10-10 12:10:36,804 sending ping to Protocol(SocketConnection(/home/xpra/.xpra/desktop-20)) with time=1412917836804
2014-10-10 12:10:36,805 add_packet_to_queue(ping ...)
2014-10-10 12:10:36,805 process_focus: wid=0

That's 6 seconds between the reception of the focus event and its actual processing in the main loop!

Attachments (1)

reaper-bug.patch (1.2 KB) - added by Antoine Martin 6 years ago.
"fixes" the hangs: where we initialise the reaper causes this weird bug

Download all attachments as: .zip

Change History (3)

comment:1 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to Antoine Martin
Status: newassigned

So this is caused by r7743, which looks innocuous!

Changed 6 years ago by Antoine Martin

Attachment: reaper-bug.patch added

"fixes" the hangs: where we initialise the reaper causes this weird bug

comment:2 Changed 6 years ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Fixed in r7928!

Note: See TracTickets for help on using tickets.