xpra icon
Bug tracker and wiki

Opened 4 years ago

Closed 4 years ago

#722 closed defect (invalid)

Using --password= and --password-file= causes SSH to fail to login

Reported by: J. Max Mena Owned by: Antoine Martin
Priority: major Milestone:
Component: client Version: trunk
Keywords: Cc:

Description (last modified by Antoine Martin)

Tested with Win7 r7897 against a Fedora 20 r7897 server:

Connecting to the server (started with xpra start :13 --no-daemon --start-child=xterm) with xpra attach ssh:jimador@10.0.32.52 --password-file="C:\password.txt" causes the password prompt to pop up, and after entering the correct password, the server and client prints:

Protocol(SocketConnection(/home/jimador/.xpra/camarena.spikes.eng-13)): authentication error (this server does not require authentication)

Upon entering the incorrect password into the dialogue, the password dialogue pops back up asking for a password again.

I have tried all the permutations:

  • Client with --password-file with correct password and correct password into prompt
  • Client with --password-file with incorrect password and correct password into prompt
  • Client with the correct password entered into the password field on the launcher, and correct password into prompt
  • Client with the incorrect password entered into the password field on the launcher, and correct password into prompt

The only way to successfully connect with SSH is to NOT supply a password, and then enter it into the dialogue box.

Change History (1)

comment:1 Changed 4 years ago by Antoine Martin

Description: modified (diff)
Resolution: invalid
Status: newclosed

This is not a bug.
The password-file switch (which is the only switch that should be exposed, --password isn't meant to be used), is only meant to be used for xpra's own authentication, not for SSH.
SSH does its own authentication, using keys, passphrases, password prompts and whatnot.

Note: See TracTickets for help on using tickets.