xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 4 years ago

Last modified 13 months ago

#724 closed defect (fixed)

System tray not able to change options with mix of left and right clicks

Reported by: rikky Owned by: Antoine Martin
Priority: blocker Milestone:
Component: client Version: 0.14.x
Keywords: Cc:

Description

I can not change any option from the xpra tray. Tried to change Encoding, Quality,Speed, Speaker, Microphone, Keyboard. Only "Keyboards Synchronization" can be changed. May be related to submenus?

I had this behavior for many versions (I guess since the 0.12.x), but I blamed my old ubuntu installation. After updating to newer Ubuntu the issue persists.

Server: Ubuntu 14.04 with Xpra 0.14.10
Client: Windows 7 with Xpra 0.14.10

Attachments (1)

tray-mixed-clicks.patch (3.6 KB) - added by Antoine Martin 5 years ago.
proposed fix

Download all attachments as: .zip

Change History (17)

comment:1 Changed 5 years ago by Antoine Martin

Owner: changed from Antoine Martin to rikky

If you right click on the tray to get the menu, you have to right click on the options. (same for left click)
Apart from that, there are no known issues with the tray menu. I doubt that the server version could influence that.

Does this happen with all sessions? Even with just an xterm as application?

Is this a regression? Did not occur with versions older than 0.12.x? If so, can you download older version to pinpoint when the problem started?

comment:2 Changed 5 years ago by rikky

You are right. I tend to right click on tray icons, but It never occured to me to right click on a menu item.

Since I could not find an existing bug report for this behavior, I would like to keep this one open. Would be nice to not close the menu when clicking with the wrong button, or even better always react on left click.

comment:3 Changed 5 years ago by Antoine Martin

Summary: System tray on Windows not able to change optionsSystem tray on Windows not able to change options with mix of left and right clicks

I believe I have just come up with a quick fix for this bug.
Can you please test it for me? Then I can commit and backport it.
There is a beta windows build (named r8044M)

Changed 5 years ago by Antoine Martin

Attachment: tray-mixed-clicks.patch added

proposed fix

comment:4 Changed 5 years ago by rikky

The beta build did not fix the issue. The options don´t change when left clicking on a menu item after opening the tray menu with a right click. But there is an additional issue. After opening the menu with a right click and clicking on an option with a right click, the old option is not removed and you see multiple active options.

comment:5 Changed 5 years ago by Antoine Martin

Wait, I've just tried again and I am unable to reproduce the bug, even with older builds. What am I missing?
Can you give us a more detailed, step by step reproduction?
I've tried left then right, right then left, no difference, both work, even with older versions. Tested with XP and Windows 7 Ultimate 64-bit.

comment:6 Changed 5 years ago by rikky

Ok I´ll try:

  1. right click on the Xpra tray icon
  2. Move the mouse over "Encoding", to open that sub menu (I did not click it)
  3. left click on JPEG

The menu will close. But if you open the menu again, the old encoding is still active and not JPEG.

comment:7 Changed 5 years ago by Antoine Martin

Owner: changed from rikky to Antoine Martin
Status: newassigned

Right, my bad. It's only (edited) radio checkboxes.
Let me see what I can do.

Last edited 5 years ago by Antoine Martin (previous) (diff)

comment:8 Changed 5 years ago by Antoine Martin

Owner: changed from Antoine Martin to rikky
Status: assignednew
Summary: System tray on Windows not able to change options with mix of left and right clicksSystem tray not able to change options with mix of left and right clicks

The proposed fix was almost right, but not quite.
Once I knew how to reproduce, it was a bit easier to figure out: r8064 fixes this.
Will backport.

I've also edited the bug title to remove "windows" because this also affected other platforms - it was just a bit harder to hit.

@rikki: new beta build 8064
does that fix things for you?

comment:9 Changed 5 years ago by rikky

Resolution: fixed
Status: newclosed

r8064 works great. Thanks.

comment:10 Changed 5 years ago by Antoine Martin

Backport for v0.14.x was in r8074.

We also need r8113 to avoid breaking the gtk3 port.. (backported in r8116)

Last edited 5 years ago by Antoine Martin (previous) (diff)

comment:11 Changed 4 years ago by Antoine Martin

Priority: minorblocker
Resolution: fixed
Status: closedreopened

Re-opening: I am seeing some problems with this code, both with the speed / quality sub menus and with the callbacks firing multiple times (blocking ticket:808#comment:8).

comment:12 Changed 4 years ago by Antoine Martin

Owner: changed from rikky to Antoine Martin
Status: reopenednew

This is fixed (again - but properly this time?) in r9002.

Needs backporting so keeping this ticket open.

comment:13 Changed 4 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Backport in r9002. Works fine so closing. Feel free to re-open if I've missed something.

comment:14 Changed 4 years ago by Antoine Martin

FYI: this caused a bug somewhere else on win32: #864.

comment:15 Changed 4 years ago by Antoine Martin

r9442 changes the code so we only ever enable the workaround on win32 (trunk 0.16 only)

Last edited 4 years ago by Antoine Martin (previous) (diff)

comment:16 Changed 13 months ago by Antoine Martin

The problem may have reappeared: #1907

Note: See TracTickets for help on using tickets.