xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 5 years ago

#742 closed defect (invalid)

connection timeout error after update to Mac OS X 10.10 Yosemite - forticlient

Reported by: Bruno Orcha García Owned by: Bruno Orcha García
Priority: major Milestone:
Component: client Version: 0.14.x
Keywords: Cc: gimcoo@…

Description

When trying connect to a remote linux xpra session from a xpra client on MacOSX, both version 0.14.2, a timeout error shows on the server log and the connection stop. I tried using ssh connection and tcp connection, but the same timeout error shown. I attach the logs from the client and server in debug mode.

Attachments (9)

server-side-linux.log (28.1 KB) - added by Bruno Orcha García 5 years ago.
Server Side log
client-side-macosx.log (116.9 KB) - added by Bruno Orcha García 5 years ago.
Client Side log
client-side-macosx-tcp.log (117.4 KB) - added by Bruno Orcha García 5 years ago.
Client Side log using tcp:
server-side-linux-tcp.log (30.0 KB) - added by Bruno Orcha García 5 years ago.
Server Side log using tcp:
nooptions-xpra-info.log (9.6 KB) - added by Bruno Orcha García 5 years ago.
xpra info with --no-* options
nooptions-server-side-on-windows7-connect.log (639.4 KB) - added by Bruno Orcha García 5 years ago.
nooptions-client-side-windows7-working.log (177.6 KB) - added by Bruno Orcha García 5 years ago.
nooptions-client-side-macosx-not-working.log (115.8 KB) - added by Bruno Orcha García 5 years ago.
nooptions-server-side-on-macosx-connect.log (104.2 KB) - added by Bruno Orcha García 5 years ago.

Download all attachments as: .zip

Change History (21)

Changed 5 years ago by Bruno Orcha García

Attachment: server-side-linux.log added

Server Side log

Changed 5 years ago by Bruno Orcha García

Attachment: client-side-macosx.log added

Client Side log

comment:1 Changed 5 years ago by Bruno Orcha García

Cc: gimcoo@… added
Version: trunk0.14.x

comment:2 Changed 5 years ago by Antoine Martin

Owner: changed from Antoine Martin to Bruno Orcha García

From your client-side log, I see:

Connection to the xpra server via SSH failed for: ssh:brunoorcha@brunoorcha.guadaltel.es:100
 the command line used was: ['ssh', '-l', 'brunoorcha', '-T', 'brunoorcha.guadaltel.es', 'xpra initenv || echo "Warning: xpra server does not support initenv" 1>&2;~/.xpra/run-xpra _proxy :100']
 check your username, hostname, display number, etc
internal error: read connection TwoFileConnection(ssh:brunoorcha@brunoorcha.guadaltel.es:100) closed: \
   cannot read using ['ssh', '-l', 'brunoorcha', '-T', 'brunoorcha.guadaltel.es', 'xpra initenv || \
    echo "Warning: xpra server does not support initenv" 1>&2;~/.xpra/run-xpra _proxy :100']: the SSH process has terminated with exit code=0

So, for whatever reason, this ssh command failed - and it shouldn't.
Try to run it by hand to figure out the reason:

comment:3 Changed 5 years ago by Bruno Orcha García

Hello, the ssh connection works fine (no password prompt needed). If I try the command ssh -l brunoorcha -T brunoorcha.guadaltel.es, I see the motd of the remote machine (without a shell due a -T option). Anyway, I've tried using the tcp connection also, and got the same result, timeout error. I'll attach the tcp option logs.

Changed 5 years ago by Bruno Orcha García

Attachment: client-side-macosx-tcp.log added

Client Side log using tcp:

Changed 5 years ago by Bruno Orcha García

Attachment: server-side-linux-tcp.log added

Server Side log using tcp:

comment:4 Changed 5 years ago by Antoine Martin

That's very odd. Very useful to have tried both TCP and SSH.
If it was just the TCP having problems, I would have suspected that a transparent proxy or firewall was interfering. But since you're having the same problem with SSH mode, the problem must be on the server and is not related to the transport at all. At least we've eliminated something.

What is your server OS / distro / version / etc?
Can you run xpra info against that server once started? That's a very basic test and exercises the same code as a real connection.
Other things I can suggest to try (though I can't really see why they would matter): remove as many features as you can when starting the server (--no-speaker, --no-clipboard, etc..)

comment:5 Changed 5 years ago by Bruno Orcha García

I've init the server with the next command:

xpra start :100 --bind-tcp=192.168.60.179:8080 -d all --no-fake-xinerama --no-mdns \
--no-pulseaudio --no-dbus-proxy --no-clipboard --no-notifications --no-system-tray \
--no-cursors --no-bell --no-xsettings --no-mmap --no-sharing --no-speaker \
--no-microphone --no-windows --no-tray --no-keyboard-sync

The same timeout error on MacOS X.

But I'm not sure that the problem is on the server side. Using VirtualBox?, I can connect to the same linux server from a Windows 7 virtual machine and from an other linux virtual machine. I've tried to connect from two distinct MacOS X machine (macbook adn iMac, both with the OS MacOSX Yosemite 10.10) and the error is the same, so I think probably the problem is on the MacOSX client.

I'll attach the xpra info, the server and the two client logs (a working and a not working session)

Changed 5 years ago by Bruno Orcha García

Attachment: nooptions-xpra-info.log added

xpra info with --no-* options

Changed 5 years ago by Bruno Orcha García

Changed 5 years ago by Bruno Orcha García

Changed 5 years ago by Bruno Orcha García

Changed 5 years ago by Bruno Orcha García

comment:6 Changed 5 years ago by Antoine Martin

I can connect to the same linux server from a Windows 7 virtual machine and from an other linux virtual machine


Ah, OK. Then back to the drawing board.

You could try downgrading the OSX Xpra version, try 0.14.0, 0.13.x or even older.

comment:7 Changed 5 years ago by Bruno Orcha García

I've tried Xpra versions 13.9 and 12.7, the same timeout error :(

comment:8 Changed 5 years ago by Antoine Martin

Hmmm. We know for sure that those OSX versions do work, so it must be something in your environment that is causing problems. But since you've tried it on two machines.. they would need to have the same problem.
I haven't tried Yosemite myself yet, but I'm sure others have.

I'm out of ideas at this point.

comment:9 Changed 5 years ago by Bruno Orcha García

I will try other options, connect to other linux server, connect from distinct network, and someone else with Yosemite to obtain more information. Anyway, It has to be related to the update to Yosemite because both machines was working perfect before on MacOSX Mavericks (10.9).
Thanks very much for your time and support :)

comment:10 Changed 5 years ago by Antoine Martin

Summary: Timeout error on Mac OS X 10.10connection timeout error after update to Mac OS X 10.10 Yosemite

(updating bug title to make it clearer: I didn't know it worked for you before)

comment:11 Changed 5 years ago by Bruno Orcha García

We can close this ticket as invalid. After some tests I can conclude the problem is about Forticlient VPN after upgrade to Yosemite not a Xpra problem.

Before, on Mavericks, Xpra worked perfectly through the VPN connection. After upgrade to Yosemite, all the apps was working correctly using Forticlient VPN except Xpra, which was failing with the timeout errors commented above. Because that, I didn't mention the use of the Foticlient VPN client. Sorry, my fault.

Moreover, all the tests using directly the console app Xpra.app/Contents/MacOS/Xpra always fail with the timeout error, but when using the graphical launcher (Xpra_Launcher), and I try to connect, it fail with the same error ... but!, if I repeat the same connection without closing Xpra_Launcher, it connect and all works perfectly!. So it's working but fails on the first try ... a weird issue due to Forticlient.

So thank you very much for your support and I'm so sorry about the waste time.

comment:12 Changed 5 years ago by Antoine Martin

Resolution: invalid
Status: newclosed
Summary: connection timeout error after update to Mac OS X 10.10 Yosemiteconnection timeout error after update to Mac OS X 10.10 Yosemite - forticlient

After some tests I can conclude the problem is about Forticlient VPN after upgrade to Yosemite not a Xpra problem


OK, good to know.
I am changing the ticket title to reflect that (easier to google) and closing it.

Did you file a ticket with them? I think this is the second time we've had issues with them.

Note: See TracTickets for help on using tickets.