xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#762 closed defect (fixed)

Tooltips have a title bar

Reported by: John1221 Owned by: Antoine Martin
Priority: major Milestone:
Component: client Version: trunk
Keywords: Cc: lukashaase@…, ntlong0210@…

Description

I running Internet Explorer with wine 1.7.x via xpra.
Tooltips have a title bar when I move cursor around areas which can display tooltip.
I run IE from real machine and tooltips aren't display the title bar.
My Server and client use xpra version 0.14.13.

Attachments (2)

tooltip.jpg (113.6 KB) - added by John1221 5 years ago.
matlab-ttip.png (64.7 KB) - added by Lukas Haase 5 years ago.

Download all attachments as: .zip

Change History (22)

Changed 5 years ago by John1221

Attachment: tooltip.jpg added

comment:1 Changed 5 years ago by Antoine Martin

Cc: lukashaase@… added
Owner: changed from Antoine Martin to John1221

This looks similar to #755.
Original mailing list thread with the first patch can be found here: http://lists.devloop.org.uk/pipermail/shifter-users/2014-December/001091.html.

The wm spec does talk about deciding whether to use window decorations or not, and how this is related to the window types, but stops short of actually telling us which window types should be decorated and which ones should not...

So r8235 solves this by skipping decorations for any non-normal window that is transient for another window.
The latest beta windows builds have this client side fix included, does this work for you?
If so, I may backport it - though I may wait this one out for one release to just give it more time in testing.

Changed 5 years ago by Lukas Haase

Attachment: matlab-ttip.png added

comment:2 Changed 5 years ago by Lukas Haase

I added a screenshot how it looks in MATLAB. Just checked the recent client build, yeah, window decoration is gone. Great.

However, I have again weird positioning problems :-( (for example the auto completion window appears on the 2nd screen at the screen edge). I'll create a ticket for that.

comment:3 Changed 5 years ago by Antoine Martin

Owner: changed from John1221 to Antoine Martin
Status: newassigned

OK, thanks for the feedback.

I am keeping this ticket open and assigned to me until I backport this change.

comment:4 Changed 5 years ago by peterlong0210

I also checked the latest beta windows build. No longer occur. It's great.
Thank you. :)

comment:5 Changed 5 years ago by peterlong0210

Cc: ntlong0210@… added

comment:6 in reply to:  1 Changed 5 years ago by John1221

So r8235 solves this by skipping decorations for any non-normal window that is transient for another window.
The latest beta windows builds have this client side fix included, does this work for you?


Yeah. It's work. Thanks for your quick update.

Last edited 5 years ago by Antoine Martin (previous) (diff)

comment:7 Changed 5 years ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Backport in r8253. Closing.

comment:8 Changed 5 years ago by Antoine Martin

This has caused a regression with Firefox dialogs: #766.

I should probably have waited a bit longer before doing the backport...

comment:9 Changed 5 years ago by John1221

Resolution: fixed
Status: closedreopened

This issue has caused again after install xpra 0.14.15-r8327 ( windows build)

comment:10 Changed 5 years ago by Antoine Martin

There is at least one other problem with 0.14.15, so I have pulled the packages and will release 0.14.16 with the fixes instead.

comment:11 Changed 5 years ago by Antoine Martin

So... the problem is that wine uses DIALOG window type for its tooltip, which is just wrong. In restoring decorations for firefox dialogs (#766), we broke ie again. The real solution to this is to remove the heuristics and just honour the "decorations" flag as per #765.

comment:12 Changed 5 years ago by Antoine Martin

Just for my own reference, here's how I got IE7 running on Fedora 20 using winetricks:

sudo yum install wine
wget http://winetricks.org/winetricks
chmod +x winetricks 
export WINEPREFIX=$HOME/.wine32
export WINEARCH=win32
winecfg
./winetricks ie7
wine ~/.wine32/drive_c/Program\ Files/Internet\ Explorer/iexplore.exe "$@"

(you will need to set the env before running iexplore again, or make a script, or ...)

comment:13 Changed 5 years ago by Antoine Martin

Lots of fixes required to get this right, see 765#comment:10 for details.

Beta 0.14.16 and 0.15.0 packages with all these changes can be found here: http://xpra.org/beta/

John1221 / peterlong0210: any kind of testing feedback would be much appreciated.

comment:14 Changed 5 years ago by John1221

I upgraded both server and client.
Server(precise) upgrade to 0.14.16
Client(window) upgrade to 0.14.6-r8343 and 0.15.0-r8339

And the problem is gone. Great!
Firefox's dialogs were decorated.
The problem at #765 was also resolved.
And tooltips of IE with wine were no longer decorated.
All above tested from client with 2 versions 0.14.16 and 0.15.0

comment:15 Changed 5 years ago by John1221

But when maximize Chrome can cause taskbar go to the background.

comment:16 Changed 5 years ago by John1221

I don't know why and can't reproduce, but when testing xpra version 0.15.0 and 0.14.16, I saw a problem:
After #713 occur in my client, I detached xpra and reattach => When xpra resumed, all windows opened by xpra were continuous flashing, the active window was changing for an infinite-loop.
I tried to reproduce it, but I can't reproduce #713.

comment:17 Changed 5 years ago by Antoine Martin

Resolution: fixed
Status: reopenedclosed

When xpra resumed, all windows opened by xpra were continuous flashing


I'm pretty sure what you saw is fixed in r8352.
I could reproduce it by minimizing and restoring a window very quickly until the system got stuck in this loop, continuously flashing the window. I have uploaded updated beta builds which should fix this issue.


But when maximize Chrome can cause taskbar go to the background.


Confirmed... I've modified a test application to replicate the problem: r8354.

I am moving this to a separate ticket: #771, and closing this one. Feel free to re-open if I've missed anything.

comment:18 in reply to:  17 Changed 5 years ago by John1221

I'm using xpra version 0.14.18 ( r8503 ) at both server(Ubuntu 12.04) and client(Windows 7).
I didn't find the relate ticket, and I think we created a ticket about it. So I post at here.
Replying to totaam:

When xpra resumed, all windows opened by xpra were continuous flashing


I'm pretty sure what you saw is fixed in r8352.
I could reproduce it by minimizing and restoring a window very quickly until the system got stuck in this loop, continuously flashing the window. I have uploaded updated beta builds which should fix this issue.

  1. This problem is still occur in version 0.14.18 r8503.
  2. Another problem : Chrome can't minimize by left-click in it from the taskbar, and still cause the taskbar go to background when maximized.
Last edited 5 years ago by Antoine Martin (previous) (diff)

comment:19 Changed 5 years ago by Antoine Martin

This problem is still occur in version 0.14.18 r8503.


If we are talking about "tooltips windows have a title bar", please re-open this ticket and give me instructions to reproduce (application to use, actions, etc).
If this is a different bug, please open a separate ticket.


Another problem : Chrome can't minimize by left-click in it from the taskbar, and still cause the taskbar go to background when maximized.


This sounds like two different bugs, please use separate tickets for them.

comment:20 Changed 5 years ago by Antoine Martin

New tickets related to this one:

  • #790: Windows is continous flashing in loop
  • #771: undecorated windows should not cover the taskbar when maximized on win32
  • #791: Chrome can't minimize by left-click in it from the taskbar
Note: See TracTickets for help on using tickets.