xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#764 closed defect (fixed)

Getting a seg fault on CentOS client when resizing

Reported by: alas Owned by: alas
Priority: critical Milestone:
Component: client Version: trunk
Keywords: Cc:

Description

Using a CentOS trunk client (your beta: xpra-0.15.0-20141211.el6_4.x86_64.rpm) against a fedora 20 trunk server (our build, 0.15.0 r8195), with an xterm, a firefox browser, and an epiphany browser as start-child-ren... with opengl on ... when I resize the firefox browser and scroll while it's trying to refresh, it causes a seg fault (message outputted to client-side).

As mentioned in #700, this fedora server has an "invalid webp build"... but a seg fault seems like an extreme reaction.

I'll attach an xpra info and a log from client side with -d opengl,system,encoding (unfortunately, while capturing the log, the repro took longer than any of the previous reproductions).

Attachments (2)

ticket764info.txt (154.4 KB) - added by alas 6 years ago.
xpra info CentOS trunk against fedora server
ticket764clientlogging.txt (775.0 KB) - added by alas 6 years ago.
CentOS client logs, -d opengl,system,encoding

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by alas

Attachment: ticket764info.txt added

xpra info CentOS trunk against fedora server

Changed 6 years ago by alas

Attachment: ticket764clientlogging.txt added

CentOS client logs, -d opengl,system,encoding

comment:1 Changed 6 years ago by Antoine Martin

Owner: changed from Antoine Martin to alas

This must be a valid bug, server configuration issues should never be able to crash the client - make it misbehave sure, but not crash it.

But I don't see the segfault message.

Please post the opengl info, does this occur with opengl turned off? etc...
And if possible, get me a gdb backtrace. (see wiki/Debugging)
Is your centos system really a centos 6_4 and not 6_6?

comment:2 Changed 6 years ago by Antoine Martin

Priority: majorcritical

(raising, "crashes are bad")

comment:3 Changed 6 years ago by alas

Resolution: fixed
Status: newclosed

Well, with the new 0.15.0 beta build (session info reads it as runknown) against a 0.15.0 r8661 fedora 20 server... I can't reproduce this at all.

Closing for now (will consider re-opening if our build re-introduces).

Note: See TracTickets for help on using tickets.