xpra icon
Bug tracker and wiki

Opened 6 years ago

Closed 6 years ago

#769 closed defect (duplicate)

pop up window inoperable

Reported by: Jiang Owned by: Antoine Martin
Priority: blocker Milestone:
Component: core Version: trunk
Keywords: Cc:

Description

Dear Developer,
I am utterly defeated by this bug. I have been happily using xpra, connecting to a desktop from a laptop, both running Ubuntu 14.04 (flashback session). I swear to God I did not change a thing but suddenly today, xpra becomes unusable. I spent the whole day debugging but could not figure out why. Please help me because I depend on xpra for everyday use. I am panicking and drowning here.

I started a xpra on display :100 on the server. I then attach to it, and used DISPLAY=100 screen and then start instances of application within the screen session.

It used to works perfectly. But now, sometimes when I tried to open a new window from the forwarded client, such as opening a configuration dialog box or a safe file dialog box in a firefox instance, the window will show up with no border and I cannot input text to it. I can still click buttons in it, but this makes changing configuration (e.g. proxy) unusable in xpra.

This most likely has something to do with how xpra interact with window manager on the client side. Things are fine if I forward the entire desktop to the client side. Somehow, it seems, the pop up window is unmanaged by the window manager in the client side. However, I am able to click on buttons, but cannot click on text box and enter text.

Everything was so perfect, but suddenly this happens. I could not figure out how it happened.

Please let me know what I can do to help you debugging and resolving this. I'm sorry to submit the bug during holidays. But I could not use computer without xpra for long. Thank you for making xpra and look forward to hearing from you.

Change History (1)

comment:1 Changed 6 years ago by Antoine Martin

Resolution: duplicate
Status: newclosed

Duplicate of #766

Note: See TracTickets for help on using tickets.