xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#781 closed defect (invalid)

Python openGL fail to load

Reported by: Jiang Owned by: Antoine Martin
Priority: minor Milestone:
Component: client Version: 0.14.x
Keywords: Cc:

Description (last modified by Antoine Martin)

Description:
Installed PyOpenGL_accelerate and PyOpenGL via pip as root. Using xdummy. When connecting to server, opengl rendering fail with these messages

python opengl module failed with message:

2015-01-06 16:55:59,951  __init__() takes at least 2 positional arguments (1 given)
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/xpra/client/gtk2/client.py", line 463, in init_opengl
    self.opengl_props = gl_check.check_support(min_texture_size, force_enable=(enable_opengl is True))
  File "/usr/lib/python2.7/dist-packages/xpra/client/gl/gl_check.py", line 438, in check_support
    gl_props = check_GL_support(gldrawable, glcontext, min_texture_size, force_enable)
  File "/usr/lib/python2.7/dist-packages/xpra/client/gl/gl_check.py", line 165, in check_GL_support
    from OpenGL.GL import GL_VERSION, GL_EXTENSIONS
  File "/usr/lib/python2.7/dist-packages/OpenGL/GL/__init__.py", line 3, in <module>
    from OpenGL.GL.VERSION.GL_1_1 import *
  File "/usr/lib/python2.7/dist-packages/OpenGL/GL/VERSION/GL_1_1.py", line 10, in <module>
    from OpenGL import platform, constants, constant, arrayspl
  File "/usr/lib/python2.7/dist-packages/OpenGL/arrays/__init__.py", line 19, in <module>
    from OpenGL.arrays.arraydatatype import *
  File "/usr/lib/python2.7/dist-packages/OpenGL/arrays/arraydatatype.py", line 14, in <module>
    from OpenGL_accelerate.arraydatatype import ArrayDatatype as ADT
  File "arraydatatype.pyx", line 1, in init OpenGL_accelerate.arraydatatype (src/arraydatatype.c:10964)
  File "wrapper.pyx", line 3, in init OpenGL_accelerate.wrapper (src/wrapper.c:11183)
  File "/usr/lib/python2.7/dist-packages/OpenGL/error.py", line 224, in <module>
    ErrorChecker = _ErrorChecker( platform )
  File "errorchecker.pyx", line 17, in OpenGL_accelerate.errorchecker._ErrorChecker.__init__ (src/errorchecker.c:818)
TypeError: __init__() takes at least 2 positional arguments (1 given)

Attachments (1)

781-debug-output.txt (110.0 KB) - added by Antoine Martin 5 years ago.
replacing long text with attachment

Download all attachments as: .zip

Change History (4)

comment:1 Changed 5 years ago by Antoine Martin

Description: modified (diff)
Resolution: invalid
Status: newclosed

This is a pyopengl / pyopengl accelerate installation issue, not an xpra issue. Please report it there, not here.

PS: please use attachments rather than overly long tickets in the future.

Changed 5 years ago by Antoine Martin

Attachment: 781-debug-output.txt added

replacing long text with attachment

comment:2 Changed 5 years ago by Antoine Martin

Description: modified (diff)

(see attachment for original ticket contents)

As per FAQ, this particular error was caused by mixing distribution installed opengl with a pip install of the accelerate module. The versions must match!

comment:3 Changed 4 years ago by Antoine Martin

Summary: Pythong openGL fail to loadPython openGL fail to load
Note: See TracTickets for help on using tickets.