xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 5 years ago

#783 closed defect (invalid)

webp compression can be very poor

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: critical Milestone: 0.15
Component: encodings Version: trunk
Keywords: Cc:

Description

It seems OK in lossless mode (as long as you avoid the large dimensions / low speed which cause it to choke completely), and the tests didn't look too bad.
But when I run the server in debug mode, I often see an output picture size twice as big as the input!?

r8418 fixes the complete lack of compression of the alpha channel (needs backport), but I think we may need something more drastic.
Either narrow down the settings that are actually useful with webp, or disable it completely!
It may also be worth sending plain RGB data when we find that the compressed data is bigger than the original!

Change History (1)

comment:1 Changed 5 years ago by Antoine Martin

Resolution: invalid
Status: newclosed

After fixing the alpha compression (backport was in r8422), I cannot reproduce the case where the compressed size is bigger than uncompressed.
Though it is sometime close enough that lz4 might be a better choice, I don't think it is worth bothering, the code in make_data_packet is complicated enough as it is.

Note: See TracTickets for help on using tickets.