xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 5 years ago

#788 closed defect (fixed)

OSX client GUI launcher text displaying as empty rectangles

Reported by: alas Owned by: Smo
Priority: major Milestone:
Component: client Version: trunk
Keywords: osx dialog boxes Cc:

Description

Using OSX client 0.15.0 r8522 to connect to a fedora 20 0.15.0 r8522 (technically runknown) server...

When trying to launch from the GUI, the text of the GUI all displays as empty rectangles. Likewise, all the About Xpra, Session Info, and such dialog boxes.

I'll attach a couple of screen shots.

The following outputs client-side on connection:

2015-01-21 18:24:33,954 Warning: 'rencode' packet encoder not found
2015-01-21 18:24:33,954  the other packet encoders are much slower
2015-01-21 18:24:33,954 xpra client version 0.15.0

And this when opening the About Xpra dialog:

/Users/Schadenfreude/Desktop/xpra-catalog/xpra-alex8522/Xpra.app/Contents/Resources/lib/python/xpra/client/gtk_base/about.py:88: PangoWarning: No modules found:
No builtin or dynamically loaded modules were found.
PangoFc will not work correctly.
This probably means there was an error in the creation of:
  '/Users/Schadenfreude/Desktop/xpra-catalog/xpra-alex8522/Xpra.app/Contents/Resources/etc/pango/pango.modules'
You should create this file by running:
  pango-querymodules > '/Users/Schadenfreude/Desktop/xpra-catalog/xpra-alex8522/Xpra.app/Contents/Resources/etc/pango/pango.modules'
/Users/Schadenfreude/Desktop/xpra-catalog/xpra-alex8522/Xpra.app/Contents/Resources/lib/python/xpra/client/gtk_base/about.py:88: PangoWarning: failed to choose a font, expect ugly output. engine-type='PangoRenderCoreText', script='latin'
/Users/Schadenfreude/Desktop/xpra-catalog/xpra-alex8522/Xpra.app/Contents/Resources/lib/python/xpra/client/gtk_base/about.py:88: PangoWarning: failed to choose a font, expect ugly output. engine-type='PangoRenderCoreText', script='common'

Attachments (2)

xpra-osx-0.15.0-r8522-client-GUI-Launcher.png (69.8 KB) - added by alas 5 years ago.
osx client 0.15.0 r8522 GUI launcher
xpra-osx-0.15.0-r8522-AboutXpra.png (22.3 KB) - added by alas 5 years ago.
osx 0.15.0 r8522 client about xpra dialog box

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by alas

osx client 0.15.0 r8522 GUI launcher

Changed 5 years ago by alas

osx 0.15.0 r8522 client about xpra dialog box

comment:1 Changed 5 years ago by alas

osx client 0.15.0 r8522 GUI launcher

osx 0.15.0 r8522 client about xpra dialog box

comment:2 Changed 5 years ago by Antoine Martin

Owner: changed from Antoine Martin to Smo

That's a problem with your build or packaging of GTK I am afraid... Re-assigning to smo.

Can you reproduce this with any of the beta builds I've made? (or with your build system based on the same setup)

This pango error has been discussed on the gtk-osx mailing list before.

comment:3 Changed 5 years ago by Antoine Martin

Bump - please close.

comment:4 Changed 5 years ago by alas

Resolution: fixed
Status: newclosed

Our build seems to be fixed (as of 0.15.0 r8806).

Closing.

Note: See TracTickets for help on using tickets.