xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#793 closed defect (fixed)

dependency problems on Ubuntu 14.10

Reported by: Yurlungur Owned by: Yurlungur
Priority: major Milestone:
Component: packaging Version: trunk
Keywords: Cc:

Description

When I try to install xpra/winswitch from the repositories on Ubuntu Utopic (using these instructions: http://winswitch.org/downloads/debian-repository.html) I get the error included below.I am installing the stable builds, not the beta builds.

Probably some packages are just mis-named in the dependencies list.

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 xpra : Depends: libavcodec56 (>= 6:11~beta1) but it is not installable or
                 libavcodec-extra-56 (>= 6:11) but it is not installable
        Depends: libavutil54 (>= 6:11~beta1) but it is not installable
        Depends: libswscale3 (>= 6:11~beta1) but it is not installable
        Recommends: python-lz4 but it is not installable
E: Unable to correct problems, you have held broken packages.

Change History (5)

comment:1 Changed 5 years ago by Antoine Martin

Owner: changed from Antoine Martin to Antoine Martin
Status: newassigned

Oh, thanks for the report.
That's strange because the dependencies are generated: we only specify libavcodec-dev as a Build-Depends, the rest happens automagically.

I will check in a VM.

comment:2 in reply to:  1 Changed 5 years ago by Yurlungur

Replying to totaam:

Oh, thanks for the report.
That's strange because the dependencies are generated: we only specify libavcodec-dev as a Build-Depends, the rest happens automagically.

I will check in a VM.

Oh, weird. Thanks for looking into it!

comment:3 Changed 5 years ago by Antoine Martin

Owner: changed from Antoine Martin to Yurlungur
Status: assignednew

I've just checked it in a virtual machine and I see no such problem.
Maybe you need to add the universe repository to get http://packages.ubuntu.com/utopic/libavutil54? (ie: sudo add-apt-repository universe)

comment:4 in reply to:  3 Changed 5 years ago by Yurlungur

Resolution: fixed
Status: newclosed

Replying to totaam:

I've just checked it in a virtual machine and I see no such problem.
Maybe you need to add the universe repository to get http://packages.ubuntu.com/utopic/libavutil54? (ie: sudo add-apt-repository universe)

Ah... You're right. That was the problem. Sorry for bothering you with this.

comment:5 Changed 5 years ago by Antoine Martin

No problem at all, we should have included this information on the download page - that's now done thanks to your report: http://winswitch.org/trac/changeset/5303.

Note: See TracTickets for help on using tickets.