xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 5 years ago

#807 closed defect (fixed)

Seeing an xpra child map event traceback with fedora 20 0.15.0 r8601

Reported by: alas Owned by: Antoine Martin
Priority: major Milestone: 0.14
Component: server Version: trunk
Keywords: Cc:

Description

Testing with osx 0.15.0 r8647 (our build) against a fedora 20 0.15.0 r8601 server (your latest 0202 beta build),

Whenever I hover for a second or more over a link with any sort of icon, whether it be a favorites tile on firefox, a google-app link on google-chrome, or even a to menu item on a gedit window (like the print icon), I am getting the following traceback server-side:

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/x11/server.py", line 409, in do_xpra_child_map_event
    self._add_new_or_window(event.window)
  File "/usr/lib64/python2.7/site-packages/xpra/x11/server.py", line 512, in _add_new_or_window
    self._send_new_or_window_packet(window)
  File "/usr/lib64/python2.7/site-packages/xpra/x11/server.py", line 622, in _send_new_or_window_packet
    self._do_send_new_window_packet("new-override-redirect", window, geometry)
  File "/usr/lib64/python2.7/site-packages/xpra/server/server_base.py", line 1430, in _do_send_new_window_packet
    ss.new_window(ptype, wid, window, x, y, w, h, wprops)
  File "/usr/lib64/python2.7/site-packages/xpra/server/source.py", line 1405, in new_window
    metadata.update(self._make_metadata(wid, window, propname))
  File "/usr/lib64/python2.7/site-packages/xpra/server/source.py", line 860, in _make_metadata
    get_window_id=self.get_window_id)
  File "/usr/lib64/python2.7/site-packages/xpra/server/source.py", line 65, in make_window_metadata
    strut = window.get_property("strut")
TypeError: object of type `xpra+x11+gtk_x11+window+OverrideRedirectWindowModel' does not have property `strut'

(Trying to reproduce with a fresh session, I had to open a new tab on a firefox window, before hovering started triggering the traceback. The printer icon on a gedit window seems to produce it rather readily though.)

Meanwhile, as something of an aside, whenever I try to compare with our latest fedora build trunk build, the server fails to start, with the following message:

2015-02-12 11:53:17,751 Failed to load Xpra server components, check your installation: cannot import name IDLE_TIMEOUT
2015-02-12 11:53:17,751 closing tcp socket 0.0.0.0:1201
2015-02-12 11:53:17,752 removing socket /home/jimador/.xpra/zapopan-23

They're doubtlessly not related, but they both look like they might be straightforward tracebacks to work with (though, if the IDLE_TIMEOUT mentioned above seems to be our build, might be good to have one of your betas to compare against?).

Let me know if either merits being broken out into it's own ticket.

Change History (1)

comment:1 Changed 5 years ago by Antoine Martin

Milestone: 0.14
Resolution: fixed
Status: newclosed

That's already been fixed in r8614.

Feel free to reopen if you can reproduce with a later server version.

Note: See TracTickets for help on using tickets.