xpra icon
Bug tracker and wiki

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#809 closed defect (invalid)

windows lost images

Reported by: John1221 Owned by: Antoine Martin
Priority: major Milestone: 0.16
Component: client Version: trunk
Keywords: Cc:

Description

Server: Ubuntu 14.04 amd64, xpra version 0.15.0 13-Feb-2015 08:00
Client: MS Windows 7 32bit, xpra version 0.15.0 r8661

  • Open Firefox
  • Minimize and restore instantly
  • Firefox losts all images

Attachments (2)

lost_image.png (15.7 KB) - added by John1221 4 years ago.
lost_image_log_150224.txt (87.6 KB) - added by John1221 4 years ago.

Download all attachments as: .zip

Change History (37)

Changed 4 years ago by John1221

Attachment: lost_image.png added

comment:1 Changed 4 years ago by John1221

I forgot this: Maximize Firefox first, then minimize...

comment:2 Changed 4 years ago by Antoine Martin

Milestone: 0.14
Owner: changed from Antoine Martin to John1221

Once again, I can't reproduce this one.
Can you please post "xpra info" when this happens?
Does it help if you select "raise windows" from the tray?
Does it help if you toggle opengl on or off from the tray?

Changed 4 years ago by John1221

Attachment: lost_image_log_150224.txt added

comment:3 in reply to:  2 Changed 4 years ago by John1221

Owner: changed from John1221 to Antoine Martin

Once again, I can't reproduce this one.


I will reproduce again, maybe this helps:

  • Open Firefox
  • Make sure that Firefox are maximize.
  • Minimize and restore instantly from taskbar (double click to Firefox button).
  • Firefox losts all images (likes the first screenshot).


Can you please post "xpra info" when this happens?


xpra info: attachment/ticket/809/lost_image_log_150224.txt

Does it help if you select "raise windows" from the tray?


No.

Does it help if you toggle opengl on or off from the tray?


Both server and client don't support opengl.

Last edited 4 years ago by Antoine Martin (previous) (diff)

comment:4 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to John1221

John1221: nothing there looks suspicious :(
I'll have to test with the exact same versions and OS..

Until then, does it make any difference if you use a different encoding? (ie: rgb)

comment:5 Changed 4 years ago by John1221

Owner: changed from John1221 to Antoine Martin

antoine: don't have any difference if I use others encoding ( png, rgb, jpeg,...)
After lost image, If I make the Firefox from maximize to normal state ( press restore button ), then the window images return to normal.

comment:6 Changed 4 years ago by Antoine Martin

Status: newassigned

OK, thanks.

The fact that this also affecting firefox, and also related to maximized state makes me think that this could be the same bug as #790: maybe the application thinks it isn't mapped when it is, so the contents are empty.

comment:7 Changed 4 years ago by John1221

Update: don't need to minimize and restore INSTANTLY, just need to minimize and then, restore a window.

comment:8 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to John1221
Status: assignednew

Is this fixed as per #790?

comment:9 Changed 4 years ago by John1221

Owner: changed from John1221 to Antoine Martin

@antoine: Tested with Firefox and xterm with server ( trusty, xpra 0.15 r8802), client( MS Windows 7, xpra 0.15 r8826)
Firefox is fixed, but xterm still occurs ( lost all text in xterm)

comment:10 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to John1221

Great for Firefox.
In a way, that's good, because xterm if far is easier to debug and test.

Sorry to ask again but can you give me exact steps to reproduce with just an xterm? (as simple as you can make them)

And if the bug is to do with maximize, please add to #790 instead of this one.

comment:11 Changed 4 years ago by John1221

Owner: changed from John1221 to Antoine Martin

@antoine:
Reproduce:

  1. Server-side: xpra start :100 --start-child=xterm --bind-tcp=0.0.0.0:1000 --no-cursors --no-pulseaudio --no-speaker
  2. Client-side:
    • Attach xpra : Xpra_cmd.exe attach tcp:IPADDRESS:1000
    • Open xterm, don't need maximize
    • Minimize xterm, and then restore, don't need do quickly Now xterm lost all text. Then if I maximize it -> all text appear.

Hope this helps :)

Last edited 4 years ago by John1221 (previous) (diff)

comment:12 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to John1221

Sorry for taking so long to test this very obvious bug.
The reproduction steps were very easy.

This is fixed in r9009. I think this was caused by the work in #775.
We now synchronize the "iconified" flag too when we detect a change, and not just when the window gets unmapped (hopefully this won't cause regressions).

Feel free to test the latest server builds (the client is unchanged) and report back.

Last edited 4 years ago by Antoine Martin (previous) (diff)

comment:13 Changed 4 years ago by John1221

Owner: changed from John1221 to Antoine Martin

I couldn't find the beta build r9009.
So I tested the latest server(TRUSTY) builds on 10 April, 2015(http://xpra.org/beta/trusty/main/binary-amd64/xpra_0.15.0-1_amd64.deb), the latest client(WINDOWS) builds (r8987) at the same time.
Xterm still occurs this bug.

Last edited 4 years ago by Antoine Martin (previous) (diff)

comment:14 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to John1221

@John1221: the fix is in r9009, so r8987 is too old. I have just posted some newer builds (trusty only).

Last edited 4 years ago by Antoine Martin (previous) (diff)

comment:15 Changed 4 years ago by John1221

Owner: changed from John1221 to Antoine Martin

@antoine: It works in the server builds r9016. Thank you very much.

comment:16 Changed 4 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

comment:17 Changed 4 years ago by John1221

Milestone: 0.140.16
Resolution: fixed
Status: closedreopened

This bug is reappeared.

  • Open Firefox, then open the Print dialog ( Ctrl + P ).
  • Press minimize button from the Print dialog.
  • Press Firefox from taskbar to restore.
  • Now the Print dialog lost all images, text...

Server: trusty amd64 with xpra 0.15.6-r10632
Client: MS Windows 7 64bit with xpra 0.15.6-r10632

comment:18 Changed 4 years ago by John1221

Status: reopenednew

comment:19 Changed 4 years ago by Antoine Martin

Status: newassigned

As per ticket:790#comment:31, this is apparently fixed in trunk.

If we can identify the fix in trunk, we can then backport it.. The steps in this ticket seem simple enough, so I will give it a go.

comment:20 Changed 4 years ago by Antoine Martin

Seems to be a client issue, seems broken with 0.15.7 client but ok with latest 0.16.0 beta clients, no matter which server version I connect to.
Bisecting the client:

So the problem is r10790, but it looks right and works fine in 0.16.0

And since I've spent far too much time on this already...
So I am keeping this ticket open, but will close when we stop supporting 0.15 (hopefully soon).

comment:21 Changed 4 years ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

Sorry, 0.15.x is going to be retired soon and I don't have time for this: the solution will be to upgrade clients to 0.16. Feel free to re-open if you can reproduce with a version 0.16 onwards.

comment:22 Changed 4 years ago by John1221

Resolution: fixed
Status: closedreopened

I've upgraded xpra server to 0.15.8-3, xpra client to 0.16.0-r11206.
This bug can reproduce like comment:17
I can also reproduce with xpra client version 0.16.0 r10853 and 0.16.0 r11176. Haven't test with some versions between r10853 and r11176 yet.

Last edited 4 years ago by Antoine Martin (previous) (diff)

comment:23 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to John1221
Status: reopenednew

Interesting: I tested with 0.16 latest and could not reproduce this particular problem at all (even though I did see it last time in comment:20).
I have tested with many servers:

  • Fedora 23 (both latest trunk and latest 0.15.x)
  • Ubuntu 14.04

with Firefox 42, XP client.

I did see something fishy going on with the window style: the print dialog does not have a minimize or maximize option when it first shows up but as soon as the fixup_window_style() hook runs, it does. This is fixed in r11284.
You can still use the taskbar to minimize things and try to trigger this bug.

@John1221: can you reproduce this bug with the latest win32 beta?

comment:24 in reply to:  23 Changed 4 years ago by John1221

I also tested with server(Ubuntu 14.04) and Firefox 42, but Windows 7 64bit client

It still appear with the latest r11304 win32 beta

Last edited 4 years ago by Antoine Martin (previous) (diff)

comment:25 Changed 4 years ago by John1221

Owner: changed from John1221 to Antoine Martin

comment:26 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to John1221

I have now tested again with:

  • Ubuntu 14.04 server running 0.15.8 standard package
  • Windows 7 Ultimate client with r11304 client

Still cannot reproduce.
I cannot follow the instructions from comment:17 exactly, as the minimize button is now missing from the print dialog.
I have tried using the taskbar and using the main window to minimize all firefox windows.

@John1221: can you give me more specific steps?
Can you try a few more things to narrow it down? (opengl on/off, other applications? etc..)

comment:27 in reply to:  26 Changed 4 years ago by John1221

Owner: changed from John1221 to Antoine Martin

I'm sorry. Has a mistake at here "Press minimize button from the Print dialog", it should be "Press Firefox windows button from the taskbar to minimize all Firefox windows". Maybe the Print dialog has a minimize button, but from previous version of Firefox.

I tried narrowing opengl off, and images were still good. I think my problem is opengl. From "Session Info", I can see the server doesn't support (or not yet) opengl(n/a) but the client does.

Last edited 4 years ago by Antoine Martin (previous) (diff)

comment:28 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to John1221

Maybe the Print dialog has a minimize button, but from previous version of Firefox.


As per comment:23, this was a bug in xpra - now fixed.


I think my problem is opengl. From "Session Info", I can see the server doesn't support (or not yet) opengl(n/a) but the client does.


No, this is unrelated: the server never shows its opengl information.

I can reproduce this bug with 0.15.x clients, but not with any recent 0.16.x clients.
So unless you can give me accurate and reliable steps to reproduce this bug, I will have to close this as "worksforme".

comment:29 Changed 4 years ago by John1221

Owner: changed from John1221 to Antoine Martin

Prepare:

  • Server command: xpra start :100 --start-child=firefox --bind-tcp=0.0.0.0:10000
  • Client command: <path-to-xpra-client>\Xpra-0.16.0-r11304\Xpra_cmd.exe attach tcp:IP:10000 --opengl=yes

Reproduce:

  • After Firefox was appeared, press Ctrl + P to open Print dialog (or Ctrl + O to open Open Files dialog)
  • We can call this state is (A).
  • Press Firefox button from the taskbar to minimize all Firefox windows (main window and Print dialog).
  • Press Firefox button again to restore all Firefox windows state to (A)
  • Print dialog lost all images.

You can also watch this video.

Last edited 4 years ago by Antoine Martin (previous) (diff)

comment:30 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to John1221

Watched the video and this is exactly what I am doing when testing.
The only difference being that I don't have opengl enabled in the win32 client. (because it is running in a virtual machine)
I see that you are forcing it on, why?
Have you tried disabling opengl in the client? Either from the command line or after connecting from the systray?

Last edited 4 years ago by Antoine Martin (previous) (diff)

comment:31 Changed 4 years ago by John1221

Owner: changed from John1221 to Antoine Martin

I tried disabling opengl in the client, as I said in comment:27, from the command line and this bug don't appear again.
Btw, I think if I force opengl on, the client will be using GPU and improve Xpra's performance.

comment:32 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to John1221

I tried disabling opengl in the client, as I said in comment:27, from the command line and this bug don't appear again.


Ah, I didn't understand this:

I tried narrowing opengl off, and images were still good


Please post your wiki/ClientRendering/OpenGL debugging information (the gl_check tool output from the client).
Is opengl enabled or disabled by default on your system? Is this why you force it on?

Last edited 4 years ago by Antoine Martin (previous) (diff)

comment:33 Changed 4 years ago by John1221

Owner: changed from John1221 to Antoine Martin

OpenGL debugging information from the client:

OpenGL_accelerate module loaded


OpenGL properties:
* GLU extensions           : GL_EXT_bgra
* GLU version              : 1.2.2.0 Microsoft Corporation
* accelerate               : 3.1.0
* display_mode             : DOUBLE
* gdkgl.version            : 6.1
* gdkglext.version         : 1.2.0
* gtkglext.version         : 1.2.0
* has_alpha                : True
* max-viewport-dims        : (16384, 16384)
* opengl                   : 4.2
* pygdkglext.version       : 1.0.0
* pyopengl                 : 3.1.0
* renderer                 : Intel(R) HD Graphics 4600
* rgba                     : True
* safe                     : True
* shading language version : 4.20 - Build 10.18.10.3412
* texture-size-limit       : 16384
* transparency             : False
* vendor                   : Intel
* zerocopy                 : True

Is opengl enabled or disabled by default on your system?


Opengl is enabled by default.

Is this why you force it on?


Yes, as I said. I think if I force opengl on, the client will be using GPU and improve Xpra's performance. It's right, or I misunderstand something?

comment:34 Changed 4 years ago by Antoine Martin

Resolution: invalid
Status: newclosed

If you force something on, please mention it early.
wiki/ReportingBugs clearly states that you should include the command lines for example and also clearly states: changes made to the default configuration, if any.

Had I known that you were forcing opengl on from the start, this bug would have taken minutes to close rather than the 9 months it has now taken.

Closing as invalid: we disable opengl on intel chipsets because the drivers are not reliable. Anyone second guessing the software and forcing this on should be prepared to deal with the fallout, such as this one.

comment:35 Changed 4 years ago by Antoine Martin

Note: See TracTickets for help on using tickets.