xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 5 years ago

#836 closed defect (wontfix)

centos 7 gobject warnings

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: major Milestone: 0.15
Component: server Version: trunk
Keywords: Cc:

Description

I am seeing these warnings on startup with centos 7, I think they may be legitimate:

/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+composite+CompositeHelper::shm-handle after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+composite+CompositeHelper::contents-handle after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+BaseWindowModel::opacity after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+BaseWindowModel::fullscreen after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+BaseWindowModel::has-alpha after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+BaseWindowModel::client-window after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+BaseWindowModel::xid after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+BaseWindowModel::title after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+BaseWindowModel::geometry after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+BaseWindowModel::group-leader after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+BaseWindowModel::pid after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+BaseWindowModel::can-focus after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+BaseWindowModel::window-type after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+BaseWindowModel::tray after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+BaseWindowModel::modal after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+BaseWindowModel::maximized after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+BaseWindowModel::transient-for after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+BaseWindowModel::role after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+BaseWindowModel::override-redirect after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+BaseWindowModel::attention-requested after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+WindowModel::size-hints after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+WindowModel::decorations after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+WindowModel::client-machine after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+WindowModel::icon-title after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+WindowModel::iconic after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+WindowModel::strut after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+WindowModel::icon-pixmap after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+WindowModel::user-friendly-size after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+WindowModel::state after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+WindowModel::requested-position after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+WindowModel::owner after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+WindowModel::class-instance after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+WindowModel::actual-size after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+WindowModel::requested-size after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+WindowModel::protocols after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+window+WindowModel::icon after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+wm+Wm::windows after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))
/usr/lib64/python2.7/site-packages/gobject/__init__.py:115: Warning: Attempt to add property xpra+x11+gtk_x11+wm+Wm::toplevel after class was initialised
  type_register(cls, namespace.get('__gtype_name__'))

Change History (1)

comment:1 Changed 5 years ago by Antoine Martin

Resolution: wontfix
Status: newclosed

Not a bug we can do anything about: gnome 698614.
These warnings can be triggered with the simple pygtk hello! (see Python + GTK - How to suppress warnings)

Note: See TracTickets for help on using tickets.