xpra icon
Bug tracker and wiki

Opened 4 years ago

Closed 4 years ago

#852 closed defect (fixed)

Fedora 20 and 21 0.15.0 builds are failing to stop on command

Reported by: J. Max Mena Owned by: J. Max Mena
Priority: major Milestone: 0.15
Component: server Version: trunk
Keywords: Cc:

Description

Running Fedora 20 and 21 r9137 0.15.0 servers

On running a xpra stop :13 I get the following output:

2015-05-01 14:23:01,863 Shutting down in response to request
2015-05-01 14:23:02,863 Disconnecting client Protocol(SocketConnection(('10.0.32.137', 2200) - ('10.0.11.124', 55435))): server shutdown
2015-05-01 14:23:02,884 xpra client disconnected.
2015-05-01 14:23:02,884 Disconnecting client Protocol(SocketConnection(/home/max/.xpra/ueberraschung.spikes.eng-13)): server shutdown
2015-05-01 14:23:02,885 xpra client disconnected.
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/server/server_core.py", line 279, in clean_quit
    self.cleanup()
  File "/usr/lib64/python2.7/site-packages/xpra/x11/server.py", line 326, in cleanup
    X11ServerBase.cleanup(self)
  File "/usr/lib64/python2.7/site-packages/xpra/x11/x11_server_base.py", line 489, in cleanup
    GTKServerBase.cleanup(self)
  File "/usr/lib64/python2.7/site-packages/xpra/server/server_base.py", line 577, in cleanup
    self.cleanup_pulseaudio()
  File "/usr/lib64/python2.7/site-packages/xpra/server/server_base.py", line 361, in cleanup_pulseaudio
    if self.is_child_alive(proc):
  File "/usr/lib64/python2.7/site-packages/xpra/server/server_base.py", line 562, in is_child_alive
    return proc is not None and proc.poll() is None and proc.pid not in self.child_reaper._dead_pids
AttributeError: 'ChildReaper' object has no attribute '_dead_pids'
2015-05-01 14:23:02,936 New connection received: SocketConnection(/home/max/.xpra/ueberraschung.spikes.eng-13)
2015-05-01 14:23:02,938 Connection lost
2015-05-01 14:23:03,438 New connection received: SocketConnection(/home/max/.xpra/ueberraschung.spikes.eng-13)
2015-05-01 14:23:03,439 Connection lost
2015-05-01 14:23:03,938 New connection received: SocketConnection(/home/max/.xpra/ueberraschung.spikes.eng-13)
2015-05-01 14:23:03,940 Connection lost
2015-05-01 14:23:04,439 New connection received: SocketConnection(/home/max/.xpra/ueberraschung.spikes.eng-13)
2015-05-01 14:23:04,441 Connection lost
2015-05-01 14:23:04,940 New connection received: SocketConnection(/home/max/.xpra/ueberraschung.spikes.eng-13)
2015-05-01 14:23:04,941 Connection lost
2015-05-01 14:23:05,441 New connection received: SocketConnection(/home/max/.xpra/ueberraschung.spikes.eng-13)
2015-05-01 14:23:05,443 Connection lost

The server then kicks the client, and then fails to stop. I can then reconnect if I so choose.

Change History (6)

comment:1 Changed 4 years ago by Antoine Martin

Milestone: 0.14
Owner: changed from Antoine Martin to J. Max Mena

Good catch, should be fixed in r9209.

comment:2 Changed 4 years ago by Antoine Martin

Milestone: 0.140.15

(fix milestone)

comment:3 Changed 4 years ago by J. Max Mena

Re-attempted with a Fedora 21 r9210 server:

  • xpra stop :13 now shuts down the server.

However, I am still getting Failed to shut down xpra at :13 before the server exits. The ssh session that I had the xpra server running on (with --no-daemon) shows the Xpra server exiting completely, but it does not terminate the x server. If I do a ps auxf I can see a floating Xorg.

Also I get a traceback on a shutdown request before the server exits:

2015-05-04 12:17:32,396 Shutting down in response to request
2015-05-04 12:17:33,398 Disconnecting client '/home/max/.xpra/ueberraschung.spikes.eng-13': server shutdown
2015-05-04 12:17:33,399 xpra client disconnected.
2015-05-04 12:17:33,401 stopping pulseaudio with pid 906
2015-05-04 12:17:33,452 New unix-domain connection received
2015-05-04 12:17:33,456 Connection lost
2015-05-04 12:17:33,931 xpra is terminating.
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/server/server_core.py", line 282, in quit_timer
    self.quit(upgrading)
  File "/usr/lib64/python2.7/site-packages/xpra/server/server_core.py", line 300, in quit
    self.do_quit()
  File "/usr/lib64/python2.7/site-packages/xpra/server/gtk_server_base.py", line 50, in do_quit
    gtk_main_quit_on_fatal_exceptions_disable()
  File "/usr/lib64/python2.7/site-packages/xpra/gtk_common/quit.py", line 76, in gtk_main_quit_on_fatal_exceptions_disable
    oh = _oldhook
UnboundLocalError: local variable '_oldhook' referenced before assignment
2015-05-04 12:17:34,226 New unix-domain connection received
2015-05-04 12:17:34,229 Connection lost
2015-05-04 12:17:34,453 New unix-domain connection received
2015-05-04 12:17:34,455 Connection lost
2015-05-04 12:17:34,955 New unix-domain connection received
2015-05-04 12:17:34,957 Connection lost
2015-05-04 12:17:35,455 New unix-domain connection received
2015-05-04 12:17:35,457 Connection lost
2015-05-04 12:17:35,956 New unix-domain connection received
2015-05-04 12:17:35,957 Connection lost

comment:4 Changed 4 years ago by Antoine Martin

Oh, that's odd.
This is a different one, which was caused by r9197 for #626. This is fixed in trunk in r9250 and v0.15.x in r9251.

comment:5 Changed 4 years ago by J. Max Mena

Running against an r9285 0.15.0 Fedora 21 Server I am no longer getting any warnings or errors on running xpra stop :13, and the server then shuts down cleanly.

comment:6 Changed 4 years ago by Antoine Martin

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.