xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 5 years ago

#857 closed defect (fixed)

paint error with pixmap backing and mmap

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: blocker Milestone: 0.16
Component: client Version: 0.15.x
Keywords: Cc:

Description (last modified by Antoine Martin)

process_draw 1 bytes for window 1 using mmap encoding with options={'rgb_format': 'RGB'}
draw_region(0, 0, 499, 316, mmap, 1 bytes, 1497, {'rgb_format': 'RGB'}, [<function record_decode_time at 0x7facbd53dcf8>, <function after_draw_refresh at 0x7facb4ad2b18>])
do_paint_rgb24 error
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/xpra/client/window_backing_base.py", line 274, in do_paint_rgb24
    success = (self._backing is not None) and self._do_paint_rgb24(img_data, x, y, width, height, rowstride, options)
  File "/usr/lib64/python2.7/site-packages/xpra/client/gtk2/pixmap_backing.py", line 78, in _do_paint_rgb24
    self._backing.draw_rgb_image(gc, x, y, width, height, gdk.RGB_DITHER_NONE, img_data, rowstride)
IndexError: rgb_buf is not large enough

Probably another case of #90 causing problems elsewhere.

Change History (2)

comment:1 Changed 5 years ago by Antoine Martin

Description: modified (diff)
Status: newassigned
Summary: paint error with pixmap backingpaint error with pixmap backing and mmap

comment:2 Changed 5 years ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

That was caused by the following call:

memoryview_to_bytes(<class 'xpra.net.mmap_pipe.c_char_Array_473052'>)

Which got converted to a string... r9311 fixes that. (backport to v0.15.x in r9312).

Note: See TracTickets for help on using tickets.