xpra icon
Bug tracker and wiki

Opened 4 years ago

Closed 4 years ago

#864 closed defect (fixed)

launcher crashes if we click on the encoding drop down a few times

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: blocker Milestone: 0.16
Component: client Version: 0.15.x
Keywords: win32 Cc:

Description


Attachments (1)

debug-launcher-crash.patch (1.4 KB) - added by Antoine Martin 4 years ago.
adds some debug logging

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by Antoine Martin

Attachment: debug-launcher-crash.patch added

adds some debug logging

comment:1 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to alas

This was caused by the fix for #724: somehow firing the extra event really confuses GTK on win32. No idea why.
The fix is ugly but simple: we temporarily disable the workaround when the widgets are not used from the tray.

Applied in r9439, backport to v0.15.x and v0.14.x in r9441.

@afarr: can you or Branden still cause some kind of crashes?

It is worth mentioning that I had seen the launcher crash on OSX before, just as you click on the host field to type it in. I'm not seeing this anymore, maybe it is related.

Last edited 4 years ago by Antoine Martin (previous) (diff)

comment:2 Changed 4 years ago by alas

Owner: changed from alas to Antoine Martin

Tested with win32 0.15.0 r9470 against both fedora 20 0.15.0 r9470 built --with-memoryviews and fedora 20 0.15.0 r9374 without servers.

I couldn't cause any crashes no matter what I tried, including connecting with AES and a password file.

I think this one is good to close.

comment:3 Changed 4 years ago by Antoine Martin

Resolution: fixed
Status: newclosed

Thanks!

Note: See TracTickets for help on using tickets.