xpra icon
Bug tracker and wiki

Opened 4 years ago

Closed 4 years ago

#872 closed defect (fixed)

Xpra fails to start on Fedora 22

Reported by: jonathan.underwood Owned by: Antoine Martin
Priority: critical Milestone: 0.16
Component: server Version: 0.14.x
Keywords: Cc:

Description (last modified by Antoine Martin)

So, the way Xorg is started has changed yet again for the Fedora 22 release.

On F22 XORG_BIN gets set to /usr/bin/Xorg which is a shell script that execs /usr/libexec/Xorg.wrap which is then supposed to exec /usr/libexec/Xorg after doing it's stuff, instead of /usr/libexec/Xorg.bin in F21.

So, that's the first problem - XORG_BIN should be being set to /usr/libexec/Xorg, rather than /usr/libexec/Xorg.bin. So, the logic in setup.py needs enhancing.

The second issue is then that, even when XORG_BIN is correctly set to /usr/libexec/Xorg in xpra_Xdummy, the X server fails to start with this:

(++) Log file: "/home/tom/.xpra/Xorg.:100.log", Time: Mon May 25 12:30:08 2015
(++) Using config file: "/etc/xpra/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) 
Fatal server error:
(EE) parse_vt_settings: Cannot open /dev/tty0 (No such file or directory)
(EE) 
(EE)

Downstream bug report: https://bugzilla.redhat.com/show_bug.cgi?id=1224678

Attachments (1)

xpra-0.14.22-fedora22-xorg.patch (875 bytes) - added by jonathan.underwood 4 years ago.
Patch to find the Xorg binary on Fedora 22

Download all attachments as: .zip

Change History (6)

comment:1 Changed 4 years ago by jonathan.underwood

"So, the logic in setup.py needs enhancing." should read "So, the logic in xpra_Xdummy needs enhancing."

Changed 4 years ago by jonathan.underwood

Patch to find the Xorg binary on Fedora 22

comment:2 Changed 4 years ago by jonathan.underwood

OK, there's a suggested patch to xpra_Xdummy wrapper to fix the logic for finding the Xorg binary.

The second problem, i.e. the failure of Xorg to start with the xdummy driver looks likely to be this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1203780

which is a bug with the xserver, fixed in a later package - we'll test with that and report back. In the meantime, see what you think to the simple patch.

comment:3 Changed 4 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to Antoine Martin
Priority: majorcritical
Status: newassigned

Applied in r9525 for all maintained branches.

It should be safe I think, there should not be any other distributions out there that use libexec and have an executable Xorg in there. (centos7 does not)

As for the other issue, I guess we can only wait for the fix to get pushed?
(will try it in a VM tomorrow)

comment:4 in reply to:  3 Changed 4 years ago by jonathan.underwood

Replying to totaam:

Applied in r9525 for all maintained branches.

It should be safe I think, there should not be any other distributions out there that use libexec and have an executable Xorg in there. (centos7 does not)

OK, great.

As for the other issue, I guess we can only wait for the fix to get pushed?
(will try it in a VM tomorrow)

Yes; I actually think that xorg-x11-server-1.17.1-12 will fix the issue, which is making its way to the updates repos.

comment:5 Changed 4 years ago by jonathan.underwood

Resolution: fixed
Status: assignedclosed

Confirmed, with the patch in this bug, and xorg-x11-server-1.17.1-12, xpra now starts successfully on F22. I'll close this. Thanks for applying the patch.

Note: See TracTickets for help on using tickets.