xpra icon
Bug tracker and wiki

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#877 closed defect (fixed)

clipboard hitting maximum requests per second limit

Reported by: Jiang Owned by: Jiang
Priority: critical Milestone: 0.16
Component: server Version: 0.15.x
Keywords: Cc:

Description (last modified by Antoine Martin)

Xpra 0.15 from apt repository, running on Ubuntu 14.04 on both server and client (server 32 bit, client 64 bit). Copying from one forwarded app window to another one resulting in clipboard crashing.

Debugging message on server side log shows

2015-06-01 05:24:49,027 clipboard disabled: more than 10 clipboard requests per second!

I am running a clipboard manager called parcellite on the client side, but the bug is not present in 0.14.28, which works fine with parcellite after the earlier bug I reported in ticket #703 is resolved.

Change History (9)

comment:1 Changed 4 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from Antoine Martin to Jiang

There were NO changes whatsoever in the clipboard code between 0.14 and 0.15.
Do you have sound enabled? (this did change)

It is possible that we are now handling clipboard requests faster than before, and therefore hitting the limit sooner. r9566 raises the default limit to 20 per second. I will backport to 0.15, until then you can raise the limit yourself with:

XPRA_CLIPBOARD_LIMIT=20 xpra start ...

Note: running a clipboard manager is always going to be a problem, these tools just really mess up the way the X11 clipboard was designed. Handling the clipboard is hard enough as it is, dealing with the somewhat broken behaviour from these tools is never going to be a high priority for us... sorry.

comment:2 Changed 4 years ago by Antoine Martin

Summary: Clipboard crashing on server?clipboard hitting maximum requests per second limit

(editing bug title)

comment:3 Changed 4 years ago by Jiang

I do have sound enabled.

I understand clipboard manager is a problem, so I understand that this may not be fixed completely. However, perhaps higher limit, perhaps even 40 or 50, may be helpful.

Is the limit set to prevent loops? If so, as you commented on the bug I filed for ticket #703, if there is indeed a true loop, the clipboard grow out of control and the limit will be hit very quickly however high the limit is. If there is no true loop, then the higher limit is more tolerant of normal behaviors.

Thanks for looking into this

comment:4 Changed 4 years ago by Antoine Martin

I do have sound enabled.


That explains it I think: I believe sound was acting as a rate-limiter for your clipboard requests until now by adding extra latency.

If there is no true loop, then the higher limit is more tolerant of normal behaviors


Unfortunately, that's not the case: you often just end up just crashing or making xpra so slow it becomes unusable.
I think #812 may help here.

comment:5 Changed 4 years ago by Jiang

I understand your point better now. I think being able to adjust the limit myself via XPRA_CLIPBOARD_LIMIT is a great idea, because I can then adjust the value myself without having to bother the developers, particularly since I run a clipboard manager, a non-standard setup

I did not know that the option existed! Should I change the variable on the client or the server side? Is there some documentation, either in the manpage or on the website, about this? I could add something on the appropriate place once I find out how to do this, and by trial and error find a good limit for XPRA_CLIPBOARD_LIMIT.

comment:6 Changed 4 years ago by Antoine Martin

I have added more information on the wiki/Clipboard page (look under "Notes and Tuning"), feel free to suggest more edits.

I think we can close this ticket?

comment:7 Changed 4 years ago by Jiang

Resolution: fixed
Status: newclosed

Sure. I'm too busy right now to check it (since I'm running a production system, I have to downgrade to 0.14 branch). I will check it after things calm down a bit on my end. At worst, I'll reopen the ticket if it turns out this is not the cause of the problem. Thank you again for helping!

comment:8 Changed 4 years ago by Antoine Martin

Could be related to #883.

comment:9 Changed 4 years ago by Antoine Martin

Applied to the v0.15.x branch in r9591.

Note: See TracTickets for help on using tickets.