xpra icon
Bug tracker and wiki

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#880 closed defect (fixed)

xpra session file launch fixes

Reported by: Antoine Martin Owned by: Antoine Martin
Priority: major Milestone: 0.16
Component: client Version: 0.15.x
Keywords: Cc:

Description (last modified by Antoine Martin)

Every platform needs fixes I think:

  • on win32 I get registry warnings when running ccleaner (and I think it may remove our file association if you ask it to fix it!)
  • on Linux, we are missing the mimetype association for the launcher and the launcher desktop file triggers this lintian warning: W desktop-mime-but-no-exec-code
  • osx is already tracked in #407 (not implemented yet)

Attachments (1)

test.xpra (52 bytes) - added by Antoine Martin 4 years ago.
most basic launch file I have used for testing

Download all attachments as: .zip

Change History (3)

comment:1 Changed 4 years ago by Antoine Martin

Description: modified (diff)
Status: newassigned

For Linux, following the very helpful guide: Add a custom MIME type for all users, we now add the mimetype file in r9571 and everything seems to work.
This allows us to double-click on a ".xpra" file to fire up the launcher (and optionally auto connect if autoconnect=true is set in that file).

comment:2 Changed 4 years ago by Antoine Martin

Resolution: fixed
Status: assignedclosed

I cannot reproduce the problem I had seen on win32, will follow up for osx in #407 and #641.

(this would be safe to backport)

Last edited 4 years ago by Antoine Martin (previous) (diff)

Changed 4 years ago by Antoine Martin

Attachment: test.xpra added

most basic launch file I have used for testing

Note: See TracTickets for help on using tickets.