xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 4 years ago

#881 closed defect (worksforme)

Pop-up menu of Qt5 QML running with VirtualGL becomes 1x1 pixels

Reported by: duanbw Owned by: duanbw
Priority: major Milestone: 0.16
Component: server Version: 0.15.x
Keywords: Cc:

Description

I don't know if this is a bug of Xpra or I made the wrong configuration but programs written in Qt5 QML failed to popup the menu under Xpra.
We have a program written with QML and can't be run directly using Xpra because QML uses OpenGL rendering, so I used VirtualGL to handle the OpenGL things, and Xpra as a proxy server to run this program remotely. But when I right click somewhere in the application window where it is supposed to popup a context menu, only a tiny 1x1 pixel below the mouse pointer is shown, but the menu is still functional, I can click the menu region and trigger the action, just like I have an invisible menu. This phenomenon occurs occasionally, not every time.
I wrote another quite simple QML application (in attachments as menu.tar.gz) to test, when I click the Click button, a menu is supposed to popup. But this little program needs Qt5 to compile and run. If needed, I could upload the 64bit binary, which is about 25MB with its Qt5 dependencies.
I started the server with the command
PYTHONPATH=~/xpra-versions/xpra-0.15.0/install/lib64/python ~/xpra-versions/xpra-0.15.0/install/bin/xpra start :100 --start-child=$HOME/run_menu.sh --exit-with-children --debug=all
And on the client I attach with the command
xpra attach ssh/dgy@192.168.2.145/100
I am using Xpra version 0.15.0 downloaded from the snapshots, revision 9556 I think. I build xpra from source using the following command:
python setup.py install --home=install
VirtualGL I use is version 2.4. Qt 5.1.1.
And I also tested with 0.14.24(revision 9443) and it works fine though occasionally the menu becomes 1x1 too, but not so often to be unusable.

Attachments (5)

0.14.24-with-menu.png (196.0 KB) - added by duanbw 5 years ago.
0.14.24 server, menu pops up normally on client.
0.15.0-without-menu.png (199.0 KB) - added by duanbw 5 years ago.
0.15.0 server, menu become one pixel
logs.tar.gz (329.4 KB) - added by duanbw 5 years ago.
Logs of server and information got using xpra info
menu.tar.gz (1.1 KB) - added by duanbw 5 years ago.
The little QML program I wrote for testing.
run_menu.sh (194 bytes) - added by duanbw 5 years ago.
The shell script to run my test program.

Download all attachments as: .zip

Change History (11)

Changed 5 years ago by duanbw

Attachment: 0.14.24-with-menu.png added

0.14.24 server, menu pops up normally on client.

Changed 5 years ago by duanbw

Attachment: 0.15.0-without-menu.png added

0.15.0 server, menu become one pixel

Changed 5 years ago by duanbw

Attachment: logs.tar.gz added

Logs of server and information got using xpra info

Changed 5 years ago by duanbw

Attachment: menu.tar.gz added

The little QML program I wrote for testing.

Changed 5 years ago by duanbw

Attachment: run_menu.sh added

The shell script to run my test program.

comment:1 Changed 5 years ago by duanbw

The server machine:

uname -a
Linux localhost.localdomain 3.6.10-4.fc18.x86_64 #1 SMP Tue Dec 11 18:01:27 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

The client machine:

uname -a
Linux developer.centos 3.10.0-123.el7.x86_64 #1 SMP Mon Jun 30 12:09:22 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

comment:2 Changed 5 years ago by Antoine Martin

Status: newassigned

This sounds like a duplicate of #846.
Thanks for the test application, it will make it much easier to test and fix this issue.

comment:3 Changed 5 years ago by duanbw

I don't know if you could access this website but I am really sorry that I don't have access to any file sharing sites I know outside the country. This is the 64bit binary of the test application and its dependencies, about 25MB in size. Hopefully it could make things easier.
http://pan.baidu.com/s/1i3DzVKx
(This site doesn't seem to support English, but the download button should be easy to recognize by its icon)

comment:4 Changed 4 years ago by Antoine Martin

Owner: changed from Antoine Martin to duanbw
Status: assignednew

@duanbw: how do I build the example app? There is no makefile..

comment:5 Changed 4 years ago by Antoine Martin

Assuming that this is the same problem as #846, this should now be fixed, see ticket:846#comment:9

@duanbw: does the fix work for you?

comment:6 Changed 4 years ago by Antoine Martin

Resolution: worksforme
Status: newclosed

Not heard back, closing. Feel free to re-open if this is still a problem.

Note: See TracTickets for help on using tickets.