xpra icon
Bug tracker and wiki

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#882 closed defect (wontfix)

DPI problem with Ubuntu 14.04

Reported by: Doug Doole Owned by: Antoine Martin
Priority: minor Milestone: 0.16
Component: client Version: 0.15.x
Keywords: Cc:

Description

Since upgrading my client to 0.15.0, there is something wrong with the DPI settings when I am at work and using an external monitor attached to my laptop. It results in fonts so small as to be unreadable. (The problem does not occur when I do not have an external monitor attached to my laptop. I also had not found any problems with any of the 0.14.* clients.)

The client is 0.15.0 running on Ubuntu 14.04 with KDE.

The server is 0.15.0 running on Ubuntu 14.04.

If I start the client with "xpra attach --dpi=96 ..." then everything is fine.

Attachments (3)

TinyFonts.zip (2.0 MB) - added by Doug Doole 3 years ago.
Bug Report tool output.
client.log (904 bytes) - added by Doug Doole 3 years ago.
Client side log
server.log (2.2 KB) - added by Doug Doole 3 years ago.
Server side log

Change History (9)

Changed 3 years ago by Doug Doole

Attachment: TinyFonts.zip added

Bug Report tool output.

Changed 3 years ago by Doug Doole

Attachment: client.log added

Client side log

Changed 3 years ago by Doug Doole

Attachment: server.log added

Server side log

comment:1 Changed 3 years ago by Antoine Martin

Status: newassigned
Summary: Tiny Fonts with 0.15.0DPI problem with Ubuntu 14.04

As per this post, the problem is not specific to 0.15

Last edited 3 years ago by Antoine Martin (previous) (diff)

comment:2 Changed 3 years ago by Timothy Basanov

Have the same problem, client switch --dpi=96 or --dpi=72 fixes the problem.
When --dpi=200 is used fonts in gnome menus are huge.

Server restart is not required to fix a problem.
Java applications are not affected.

Server: ubuntu 14.04
Client: Mac OS X + 30" 2500x1600

comment:3 Changed 3 years ago by psycho_zs

I can confirm this on Debian testing with xpra 0.15.2+dfsg-2.

I have 96dpi on client and 96dpi set as default on xpra server. But when I connect, I get some pretty weird values:

DPI set to 45 x 25 (wanted 96 x 96)

client --dpi switch help, but default behavior seems weirdly bugged.

comment:4 Changed 3 years ago by Antoine Martin

Priority: majorminor

AFAIK, this only occurs if you use an unpatched dummy driver, in which case it's always wrong - you just notice it less.

comment:5 Changed 3 years ago by Antoine Martin

Resolution: wontfix
Status: assignedclosed

I don't think we can do any better, the correct solution is #56. See also #728, #732.

Note: Ubuntu breaks Xdummy, please bug them to figure out why.

Last edited 3 years ago by Antoine Martin (previous) (diff)

comment:6 Changed 3 years ago by Antoine Martin

FYI: see wiki/DPI

Note: See TracTickets for help on using tickets.