xpra icon
Bug tracker and wiki

Opened 7 years ago

Closed 7 years ago

#89 closed defect (fixed)

xpra stop doesn't work and hangs

Reported by: suan Owned by: Antoine Martin
Priority: major Milestone: 0.0.7.x
Component: core Version: 0.0.7.22
Keywords: Cc:

Description (last modified by Antoine Martin)

Using xpra on Debian Lenny installed via the provided Lenny package.
Get the following when issuing xpra stop:

[email protected]:/export/web$ xpra stop :102
^CTraceback (most recent call last):
  File "/usr/bin/xpra", line 6, in <module>
    xpra.scripts.main.main(__file__, sys.argv)
  File "install/lib/python/xpra/scripts/main.py", line 159, in main
  File "install/lib/python/xpra/scripts/main.py", line 317, in run_stop
  File "install/lib/python/xpra/protocol.py", line 47, in read
KeyboardInterrupt

Change History (5)

comment:1 Changed 7 years ago by Antoine Martin

Component: servercore
Description: modified (diff)
Status: newaccepted
Version: 0.0.7.220.1.0

comment:2 Changed 7 years ago by Antoine Martin

Can you please specify the exact version you have installed?
(the line numbers from the stacktrace do not match the code in the latest release)

I have seen this problem before, but I cannot find any way of reproducing it when I want to investigate, any clues?

The best I could do was to re-write the "stop" code to use a more correct approach (and now it will also timeout rather than hang), hopefully this should fix it.
Done in r608

Last edited 7 years ago by Antoine Martin (previous) (diff)

comment:3 Changed 7 years ago by Antoine Martin

Needs r613 to make it work with password protected sessions.
This was broken previously and might have been the cause of the problem you saw, was your session password protected? (FYI: xpra sessions that are managed by winswitch will be, and recent versions will manage xpra sessions started externally too)

comment:4 Changed 7 years ago by suan

The version I was using was 0.7.22 (as specified when I originally created the ticket).

Hmm I'm not sure about password protection... I SSH into a remote box with "ForwardX11=yes, ForwardX11Trusted=yes", and use xpra there. That's where I encountered the problem.

comment:5 Changed 7 years ago by Antoine Martin

Milestone: current0.0.7.x
Resolution: fixed
Status: acceptedclosed
Version: 0.1.00.0.7.22

Hah, sorry, I just assumed this was a mistake: you should not be running anything that old.

Please use 0.1.0 (or even trunk to get the fixes above) - feel free to re-open this ticket if you can reproduce with a more recent version.

Note: See TracTickets for help on using tickets.