xpra icon
Bug tracker and wiki

Opened 4 years ago

Closed 4 years ago

#943 closed enhancement (duplicate)

Allow Windows to be directed to a specific client when using sharing

Reported by: Scott Bennett Owned by: Scott Bennett
Priority: major Milestone: 0.16
Component: server Version: trunk
Keywords: Cc: Smo

Change History (6)

comment:1 Changed 4 years ago by Antoine Martin

Description: modified (diff)

comment:2 Changed 4 years ago by Scott Bennett

Owner: changed from Antoine Martin to Scott Bennett

comment:3 Changed 4 years ago by Scott Bennett

Status: newassigned

proposed functionality:

new option:

window_per_client=on
Enables this feature, to be used in conjunction with existing 'sharing' feature

possibly a new protocol command like: 'openclient <command>'
where <command> is the shell command to run that (we would assume) would create a windowed application

Applications opened with this command would be 'associated' with the client who issued them and screen updates to this application would only be sent to the client who initiated them.

This would imply some association to be made between the windows an application starts
and a specific client. This would rely on the application to properly set window properties to associate it's child windows.

Many questions still remain at this time and a more detailed spec is certainly required.

Assuming we can do the above, directing mouse and focus events to a specific application per client (and not others than may exist at the same screen co-ordinates) remains a large hurdle to overcome.

Requesting comments at this time.

comment:4 Changed 4 years ago by Scott Bennett

Cc: Smo added

comment:5 Changed 4 years ago by Antoine Martin

Should probably be closed as a duplicate of #489.

comment:6 Changed 4 years ago by Scott Bennett

Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.