xpra icon
Bug tracker and wiki

Opened 21 months ago

Closed 12 months ago

Last modified 11 months ago

#977 closed defect (worksforme)

./setup.py install --home=install tries to create '/etc/xpra'

Reported by: a3nma3nm Owned by: a3nma3nm
Priority: major Milestone: 1.0
Component: packaging Version: trunk
Keywords: Cc:

Description

Hi,

When trying to compile trunk and installing as a local user with "./setup.py install --home=./install", installation fails with "error: could not create '/etc/xpra': Permission denied".

The exact steps to reproduce this are:

svn co https://www.xpra.org/svn/Xpra/
cd Xpra/trunk/src
# uncomment line 619 in setup.py to avoid an error in gtkitemfactory.h
./setup.py build # completes without errors
./setup.py install --home=./install

I am using Debian stretch/sid, and the Debian package "xpra" is not installed.

Of course it is normal that setup.py doesn't get permission to create /etc/xpra -- the point is that it shouldn't try to do so, when "--home=./install" is passed.

Thanks for your help on this!

Change History (5)

comment:1 Changed 21 months ago by Antoine Martin

Milestone: 0.16future
Status: newassigned

out of time, and this stuff is always harder than it looks - rescheduling

see also #908

comment:2 Changed 13 months ago by Antoine Martin

Component: corepackaging
Milestone: future0.18
Owner: changed from Antoine Martin to a3nma3nm
Status: assignednew

This should be fixed in r12572 + r12573 + r12575.

@a3nma3nm: if this works for you, please close

Last edited 13 months ago by Antoine Martin (previous) (diff)

comment:3 Changed 12 months ago by Antoine Martin

Resolution: worksforme
Status: newclosed

Not heard back closing, feel free to re-open.

comment:4 Changed 11 months ago by a3nma3nm

Sorry for the lag. I confirm that it works for me, thanks for addressing this!

comment:5 Changed 11 months ago by Antoine Martin

Milestone: 0.181.0

Milestone renamed

Note: See TracTickets for help on using tickets.