xpra icon
Bug tracker and wiki

Changes between Version 97 and Version 98 of Dependencies


Ignore:
Timestamp:
01/18/19 09:04:14 (7 months ago)
Author:
Antoine Martin
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • Dependencies

    v97 v98  
    1515||[http://pyopengl.sourceforge.net/ pyopengl]||[https://pypi.python.org/pypi/PyOpenGL] and [[BR]] [https://pypi.python.org/pypi/PyOpenGL-accelerate]||[/wiki/ClientRendering/OpenGL OpenGL accelerated rendering]||client|| ||
    1616||[https://github.com/zdohnal/pycups pycups]||[https://pypi.org/project/pycups/]||[/wiki/Printing]||both|| ||
     17|||||||||||| - ||
    1718||||||||||||[/wiki/Network Network]: ||
    1819||[https://github.com/aresch/rencode rencode]||[https://pypi.python.org/pypi/rencode/]||[/wiki/PacketEncoding#BencodevsRencode PacketEncoding : rencode vs bencode]||both ||Recommended ||
     
    2122||[http://www.oberhumer.com/opensource/lzo/ python-lzo]||[http://www.oberhumer.com/opensource/lzo/download/]||[/wiki/PacketEncoding lzo packet compression]||both||optional (usually unused as lz4 is better) - win32 build, see #1044||
    2223||[https://cryptography.io/en/latest/ python-cryptography]||[https://pypi.python.org/pypi/cryptography]||Encryption||both||win32 build, see ticket:876#comment:5||
    23 ||[https://github.com/sigmaris/python-gssapi python-gssapi]||[https://pypi.org/project/python-gssapi]||GSSAPI [/wiki/Authentication Authentication]||server|| #1691||
    24 ||[https://github.com/apple/ccs-pykerberos python-kerberos]||[https://pypi.org/project/kerberos/]||Kerberos [/wiki/Authentication Authentication]||server|| #1691||
    25 ||[https://www.python-ldap.org python-ldap]||[https://pypi.org/project/python-ldap/]||LDAP [/wiki/Authentication Authentication]||server|| #1691||
    26 ||[https://github.com/cannatag/ldap3 python-ldap3]||[https://pypi.org/project/ldap3/]||LDAP v3 [/wiki/Authentication Authentication]||server|| #1691||
    27 ||[https://github.com/google/pyu2f pyu2f]||[https://pypi.org/project/pyu2f/]||U2F [/wiki/Authentication Authentication]||server|| #1789||
    28 ||[https://github.com/phihag/ipaddress python-ipaddress]||[https://pypi.org/project/ipaddress/]||? ||required by another python module?||
    29 ||[https://github.com/kjd/idna python-idna]||[https://pypi.org/project/idna/]||? ||required by another python module?||
    30 ||[https://github.com/micheles/decorator python-decorator]||[https://pypi.org/project/decorator/]||? ||required by another python module?||
    31 ||[https://github.com/pytest-dev/pytest-runner pytest-runner]||[https://pypi.org/project/pytest-runner/]||? ||required by another python module?||
    32 ||[http://deprecation.readthedocs.io/ python-deprecation]||[https://pypi.org/project/deprecation/]||? ||required by another python module?||
    33 ||[https://github.com/matze/pkgconfig python-pkgconfig]||[https://pypi.org/project/pkgconfig/]||? ||required by another python module?||
    34 ||[https://github.com/pypa/setuptools_scm/ python-setuptools-scm]||[https://pypi.org/project/setuptools-scm/]||? ||required by another python module?||
    35 ||[https://nose.readthedocs.io/en/latest/]||[https://pypi.org/project/nose/]||? ||required by another python module?||
    36 ||[https://github.com/etingof/pyasn1 pyasn1]||[https://pypi.org/project/pyasn1/]||? ||required by another python module?||
    37 ||[https://github.com/wbond/asn1crypto asn1crypto]||[https://pypi.org/project/asn1crypto/]||? ||required by another python module?||
    38 ||[https://github.com/pypa/packaging python-packaging]||[https://pypi.org/project/packaging/]||? ||required by another python module?||
    39 ||[https://github.com/pyparsing/pyparsing/ pyparsing]||[https://pypi.org/project/pyparsing/]||? ||required by another python module?||
    40 ||[https://github.com/benjaminp/six six]||[https://pypi.org/project/six/]||? ||required by another python module?||
    41 ||[https://github.com/jstasiak/enum-compat enum-compat]||[https://pypi.org/project/enum-compat/]||? ||required by another python module?||
    42 ||[https://bitbucket.org/stoneleaf/enum34 enum34]||[https://pypi.org/project/enum34/]||? ||required by another python module?||
    43 ||[https://github.com/pypa/setuptools setuptools]||[https://pypi.org/project/setuptools/]||? ||required by another python module?||
    44 ||[https://cffi.readthedocs.io/en/latest/ cffi]||[https://pypi.org/project/cffi/]||? ||required by another python module?||
    45 ||[https://github.com/eliben/pycparser pycparser]||[https://pypi.org/project/pycparser/]||? ||required by another python module?||
    4624||[https://github.com/jstasiak/python-zeroconf python-zeroconf]||[https://pypi.org/project/zeroconf/]||? ||0.19.1 is the last version supported with python2||
    4725||[http://alastairs-place.net/projects/netifaces/ python-netifaces]||[https://pypi.python.org/pypi/netifaces]||[https://en.wikipedia.org/wiki/Multicast_DNS Multicast DNS] session publishing||server|| ||
     
    5129||[https://www.openssl.org/ openssl]||[https://www.openssl.org/source/]||SSL||both|| ||
    5230||[https://pypi.org/project/paramiko/ paramiko]||[https://pypi.org/project/paramiko/]||ssh integration||both|| ||
     31|||||||||||| - ||
     32||||||||||||[/wiki/Authentication Authentication]: ||
     33||[https://github.com/sigmaris/python-gssapi python-gssapi]||[https://pypi.org/project/python-gssapi]||GSSAPI [/wiki/Authentication Authentication]||server|| #1691||
     34||[https://github.com/apple/ccs-pykerberos python-kerberos]||[https://pypi.org/project/kerberos/]||Kerberos [/wiki/Authentication Authentication]||server|| #1691||
     35||[https://www.python-ldap.org python-ldap]||[https://pypi.org/project/python-ldap/]||LDAP [/wiki/Authentication Authentication]||server|| #1691||
     36||[https://github.com/cannatag/ldap3 python-ldap3]||[https://pypi.org/project/ldap3/]||LDAP v3 [/wiki/Authentication Authentication]||server|| #1691||
     37||[https://github.com/google/pyu2f pyu2f]||[https://pypi.org/project/pyu2f/]||U2F [/wiki/Authentication Authentication]||server|| #1789||
     38|||||||||||| - ||
     39||||||||||||Python module dependencies: ||
     40||[https://github.com/phihag/ipaddress python-ipaddress]||[https://pypi.org/project/ipaddress/]||unspecified: r11859|| ||
     41||[https://github.com/kjd/idna python-idna]||[https://pypi.org/project/idna/]||unspecified: r11860|| ||
     42||[https://github.com/micheles/decorator python-decorator]||[https://pypi.org/project/decorator/]||required by gssapi: r18781 || ||
     43||[https://github.com/pytest-dev/pytest-runner pytest-runner]||[https://pypi.org/project/pytest-runner/]||required by python-lz4: r17864 || ||
     44||[http://deprecation.readthedocs.io/ python-deprecation]||[https://pypi.org/project/deprecation/]||required by python-lz4: r17749|| ||
     45||[https://github.com/matze/pkgconfig python-pkgconfig]||[https://pypi.org/project/pkgconfig/]||required by python-lz4: r17748 || ||
     46||[https://github.com/pypa/setuptools_scm/ python-setuptools-scm]||[https://pypi.org/project/setuptools-scm/]||required by python-lz4: r15282|| ||
     47||[https://nose.readthedocs.io/en/latest/]||[https://pypi.org/project/nose/]||required by python-lz4: r8676 || ||
     48||[https://github.com/etingof/pyasn1 pyasn1]||[https://pypi.org/project/pyasn1/]||unspecified: r5829|| ||
     49||[https://github.com/wbond/asn1crypto asn1crypto]||[https://pypi.org/project/asn1crypto/]||required by python-cryptography: r17856 || ||
     50||[https://github.com/pypa/packaging python-packaging]||[https://pypi.org/project/packaging/]||required by python-cryptography: r15310|| ||
     51||[https://github.com/pyparsing/pyparsing/ pyparsing]||[https://pypi.org/project/pyparsing/]||required by python-cryptography: r15310|| ||
     52||[https://cffi.readthedocs.io/en/latest/ cffi]||[https://pypi.org/project/cffi/]||required by python-cryptography: r11633 || ||
     53||[https://github.com/benjaminp/six six]||[https://pypi.org/project/six/]||required by python-cryptography: r11640|| ||
     54||[https://github.com/jstasiak/enum-compat enum-compat]||[https://pypi.org/project/enum-compat/]||required by zeroconf: r20441|| ||
     55||[https://bitbucket.org/stoneleaf/enum34 enum34]||[https://pypi.org/project/enum34/]||required by enum-compat: r15397|| ||
     56||[https://github.com/pypa/setuptools setuptools]||[https://pypi.org/project/setuptools/]||unspecified: r5829|| ||
     57||[https://github.com/eliben/pycparser pycparser]||[https://pypi.org/project/pycparser/]||? ||required by another python module?||
    5358||[https://github.com/pyca/pynacl/ pynacl]||[https://pypi.org/project/PyNaCl/]||crypto library used by paramiko||both|| ||
    5459||[https://github.com/pyca/bcrypt/ bcrypt]||[https://pypi.org/project/bcrypt/]||crypto library used by paramiko||both|| ||